PDA

View Full Version : Problem Reinstalling Mozilla



burke3gd
05-20-2003, 12:56 PM
I tried reinstalling Mozilla to fix another problem (http://www.knoppix.net/forum/viewtopic.php?t=2472), but after using synaptic to uninstall, apt-get complains about some broken packages when I try to install it back again. This is the error message that apt-get gives me:


sudo apt-get install mozilla
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
mozilla: Depends: mozilla-browser (= 2:1.0.0-0.woody.1) but it is not going to be installed
Depends: mozilla-mailnews (= 2:1.0.0-0.woody.1) but it is not going to be installed
Depends: mozilla-psm (= 2:1.0.0-0.woody.1) but it is not going to be installed
E: Sorry, broken packages

I have tried installing different versions but nothing has so far worked. I'm a bit of Linux/Debian newbie so I would appreciate any help. :)

RockMumbles
05-20-2003, 03:54 PM
mozilla-browser (= 2:1.0.0-0.woody.1)

You are trying to get the woody 1.0.0 version of mozilla.

try this apt-get command:
apt-get install -t unstable mozilla

or go to www.apt-get.org and get an unstable URI for mozilla and put it in your /etc/apt/sources.list file (then apt-get update).

HTH

rock

burke3gd
05-20-2003, 04:32 PM
I had tried the command you suggested already but with the same response, but I had gorgot to enable my unstable source in the sources-list. Thanks for the help! :D