View Full Version : Installed Knoppix does not boot due to change in USB port

05-15-2007, 12:46 PM
I need help as I am new to Linux. I have installed the Knoppix Live CD on a USB drive by first booting it in VMWare.
1. Now whenever I try to boot it on other desktop, it fails to find root (it looks like somewhere it has hard registered the root drive as /dev/sda1) as the USB drive is now sdb instead of sda. So I have to again reboot, find the drive name (sda or sdb or sdc) and then pass it as kernel parameter. Can anyone please suggest, how can I have knoppix automatically find the root and boot without issues, I like the way xubuntu identifies drives with UUID, so even if the USB port changes, new partition arrives, the root is recognized correctly.

2. After passing the root=/dev/sdxx, booting does fail for root drive, but further it fails while executing swapon /dev/sda1 during boot (now it's sdb1), and then I am dropped to the bash shell.

It would be appreciable is someone can help me out in this. Thanks.

05-17-2007, 08:36 AM
boot with the knoppix CD and edit the fstab on /dev/sdb1 to reflect the change in root device.


Change from: /dev/sda1 / ext3 defaults

to: /dev/sdb1 / ext3 defaults

As far as mount via UUID maybe google can turn up some help... been curious about this one myself.

Take Care,
One Mynds Eye

05-25-2007, 05:48 AM
"...been curious about this one myself. .."

so I checked.... pretty straight forward:

' ls -l /dev/disk/by-uuid/ ' will show you all UUID's

The entry in /etc/fstab should look like:

# Device # Mountpoint #filesystem #Options
UUID=f9ac5b2e-cc45-4479-8871-f9fc40134cf0 / ext3 defaults,noatime 0 0

and the root= parameter for the kernel cmdline:


Take care,
One Mynds Eye