View Full Version : USB harddrives /pendrives

05-16-2007, 07:36 PM
after installing my knoppix to hardrive I am unable to veiw my usb drives. They appear on the desktop, but when i try to open my usb harddrive I get error

Could not mount Device

Thereported error was

Mount wrong fs type, bad option, bad superblock
on /dev/sda1,

missing codepage or other erro[/b]r

when i type dmesg

I get at the bottom

FAT : Unrecognized mount option "uid=knoppix" or missing value

then when i plug my pen drive inn and try to open it I get the error

Feature only available in HAL


05-17-2007, 12:39 PM
see http://www.knoppix.net/forum/viewtopic.php?t=26972 more basic stuff - the second post for more info

Try in a terminal as "root" say: mkdir /media/sda1 (if it does not exist - check your media directory first!)
then say: mount /dev/sda -t vfat /media/sda1 (and see if it mounts)
You may have to modify fstab in /etc/fstab by adding a new line with the device you want to mount
# Added by root
/dev/sda1 /media/sda1 vfat noauto,users,exec 0 0

for Live CD only - then save your config in "start - knoppix - configure - save knoppix configuration" so it boots with the changes the next time you use knoppix -- - at the boot prompt press F2 and type knoppix myconfig=scan to load your configuration file on hard disk.
Read the cheetcodes

05-17-2007, 03:42 PM
That Works fine but I can't change the Read Write mode for the mounted drives

05-18-2007, 12:15 PM
Go back and read the notes at the bottom section of the post referenced in the last post (above0

1. BEFORE you mount a drive set the read and write check box in the properties/device tab then mount the drive.

If you mounted a drive in a terminal you still need to un-mount then remount with the new settings or set the variables in fstab or mtab in your /etc/ folder for the changes to take effect
further you can create and assign a group name to have such permissions to devices and special functions from SETTINGS - USERS & GROUPS in root.
Your best ally is to read the info & manpages for instructions.

05-18-2007, 05:35 PM
Got that working

But what happened to the simple right context menu Change read/write mode. Nothing happens anymore

When i plug unplug the device it doesn't disapear on the desktop

is there a way to make them read/write always. usb listed as rw in mtab. and i even tried adding the rw param in fstab, but nothing happens

06-10-2007, 10:20 PM
I don't know the answer to that?
However I suspect (in my case anyway) because the drive was formatted in Windows as a DOS partition the problems emanate from UNIX reading the blocks from zero instead of the offset created when windows formatted the drive.
see my other post for a brief description about FAT drives created in windows vs. UNIX.
I have another USB formatted in ext2 to test that theory but have not had the time yet.
If you find the answer please share your results.

Peace & Prosperity,