View Full Version : Knoppix 5.1 stalls at Looking for CD in: /dev/hdb

08-11-2007, 09:29 PM
I have setup a flash disk based install, using several different variations of directions, and all have the same problem.

My latest attempt is based off of:
Got Knoppix 5.0.1 successfully booting from USB key

The system is an LE-363 embedded board with an AMD Geode GX2 processor. 256 MB ram, 1 GB flash disk.

This does not happen if I boot from the CD directly.

The system successfully boots up to the Knoppix startup menu, then I enter "knoppix dma screen=800x600 depth=24". The screen stuff is because X doesn't properly setup the desktop, instead using 1024x786 so I loose 1/3 of the desktop. I have tried with and without DMA.

The system starts booting:

Running Linux Kernel 2.6.19
Total Memory Available: 246648kB, Memory free: 238980kB.
Scanning for USB/Firewire devices... Done.
Enabling DMA acceleration for: hdb [(none)]
Looking for CD in: /dev/hdb

It stalls/freezes/delays here for ~120 seconds. It then sweeps through all of the dev directory:

Looking for CD in: /dev/hdc
Looking for CD in: /dev/hdd
though those are all printed on one line. Then finds the image and continues booting without any errors.

It continues with:

Accessing /dev/hdb4...
Found primary KNOPPIX compressed image at /cdrom/KNOPPIX/KNOPPIX.
Creating /ramdisk ....

Anybody have any ideas to solve this?

Thanks, Paul

11-11-2007, 10:24 PM
Well I have tried many other things, I am hoping that someone might come up with an idea.

Another bit of information, since it's a compact flash card on this motherboard, it get setup as IDE primary slave, and linux treats it as hdbx. Incidentally, all of these iterations do finally boot to a working operating system, just with the 2 minute delay.

I have used syslinux.cfg as the previously mentioned directions use. I have also set it up with lilo, using both a Fat16 and Ext2 file systems.

I have tried specifying different versions of BOOT_IMAGE in both syslinux.cfg and lilo.cfg.

Neither show any improvements, nor changes in symptoms.

When it is looking for the image, I believe this is the "linux" and "minirt.gz" files from the boot directory. Is this another re-masterable piece of Knoppix?

Any other ideas?

Thanks, Paul.

11-12-2007, 01:55 AM
Another thought or two came to mind...

When it says it's looking in /dev/hdb, does it mean /dev/hdb exactly? Ie without regard to partitions? It seems that it might be since it does find the image later at /dev/hdb4 or /dev/hdb1 depending on whether its the "cd on usb key" or "compact flash hard drive" install methods.

If this has credence as an idea, then how do I solve it? I am going to try building a compact flash hard drive without partitions. I don't know if it's possible, and I doubt that it's going to work, but I am out of ideas. Any thoughts on how to make the boot process try the partitions rather than the raw device?

I have tried BOOT_IMAGE=/dev/hdb4/KNOPPIX/KNOPPIX, but I don't think I have tried it on the compact flash/hard drive install. I will have to try that.

I have tried BOOT_IMAGE=/cdrom/KNOPPIX/KNOPPIX, but is the link between /dev/hdb1 and /cdrom only made after this step?

Thanks again for any ideas anybody might have.

12-04-2007, 03:42 AM

I experienced a similar problem creating an install that would boot and run from compact flash, but I wasn't patient enough to wait 2 minutes to see if it would find the KNOPPIX image. I don't remember the exact symptoms or what specifically I did to fix it. I do have it working, however, and it doesn't hesitate on boot. I posted my documentation in the topic "Booting Knoppix without CD and with ISO image and PH?" on this forum. You may want to look it over and see if something I did might address your problem.

12-13-2007, 01:50 AM

I just built a diskless/fanless Knoppix box and rediscovered the delay in finding the image on the CF. The fix in my case is using the "nodma" cheat code during bootup. This may be more a generic problem than specific to Knoppix. I have another machine running Ubuntu 7.10 from a hard drive. It has a CF/IDE adapter as the slave on the same IDE port. If I put a CF in the adapter, Ubuntu hangs for a little over two minutes, then boots normally. Maybe a Debian thing?