View Full Version : Sandisk goes invisible after "Create persistent ...&quo

Hal Morris
09-11-2007, 12:08 AM
I'm running Knoppix 5.0 on an HP Vectra. Got a Sandisk Cruzer Micro USB Flash Drive (1.0 Gb) today, plugged it in, started Knoppix and it looks good. It's not initially mounted but I "mount /media/sda1", it looks like VFAT I think, I cd to it poke around, and find various files with sandisk in their names -- a lot of images, and software that came with the drive.

Now, I click on the Penguin, and select configure => Create a persistent Knoppix disk image.

I select /dev/sda1, and say "no encryption please", and it procedes to format the disk as an ext2 (I think) file system. OK, there goes the Sandisk software, no tragedy, but it says if I say "home=/dev/sda1" to the book prompt, all will be well.

But no, instead Knoppix no longer recognizes the Sandisk. This time when it comes up there IS no /media/sda1 or /dev/sda1, and I have no idea what to do.

I'd hoped to copy Knoppix onto the Flash drive (probably not quite that simple, or is it?) but I can't if Knoppix no longer knows the drive is there.

I hope someone has an idea what to do.

OOPS, now it's visable again. Maybe because I moved it to the 1st slot (think it was in the 2nd before, leaving 1st empty), maybe just because I removed iit and put it back in. Maybe because I did NOT say "home=/dev/sda1" Anyway, I could mount /media/sda1, and it contained reasonable looking things like knoppix.img I think. Also it said it was VFAT type (so much for my recollection that it said it was formatting it as ext2).

FWIW, during boot-up, at some point a sort of grey box appeared with various choices as to what should be done with /dev/sda1. It timed out and I suppose took the default action after a few seconds, so I can hardly tell you anything about it.

OOPS again, rebooted, having made NO physical changes, and once again, no /media/sda1. Shut down, removed the flash drive, switched machine back on and only THEN plugged in the flash drive (maybe sounds crazy but some procedure I ran across said to do something like that. AGAIN no /media/sda1.

Shut down, unplugged system, put flash drive back in, switched back on -- still no luck and no /media/sda1.

What the?? Any ideas??

Thanks, Hal