View Full Version : apt-get upgrade issue even with persistent fs

01-19-2008, 10:29 PM
Hi, I have a persistent home directory at /home/knoppix and am booting the DVD from "knoppix bootfrom=/dev/hda2/knoppixdvd.iso". The knoppix hacks book said I could use the normal debian package management tools so I did a "sudo apt-get upgrade" and figured that the unionfs would orchestrate the updates against the live dvd using my persistent storage. I ran into trouble, which is why I'm posting.

The dvd is KNOPPIX_V5.1.1CD-2007-01-04-EN.iso, checksum-verified and has worked fine although I bootfrom a hard link to it called knoppixdvd.iso to make life easier.

The apt-get upgrade problem occurs after all the 700+ upgrades have been downloaded; then an ioctl problem happens, here's the information (where you see iinfo, remove one of the i's; I had to do this to avoid the spam filter):

xserver-xorg-dev xserver-xorg-input-all xserver-xorg-input-wacom xserver-xorg-video-all
xserver-xorg-video-fbdev xserver-xorg-video-neomagic xtrans-dev xutils-dev xvier xvncviewer
744 upgraded, 0 newly installed, 0 to remove and 1819 not upgraded.
Need to get 0B/1229MB of archives.
After unpacking 109MB disk space will be freed.
Do you want to continue [Y/n]? y
Reading changelogs... Done
apt-listchanges: Do you want to continue? [Y/n]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
supported_versions: WARNING: Unknown Debian release: None
(Reading database ... 477769 files and directories currently installed.)
Preparing to replace coreutils 5.97-5 (using .../coreutils_5.97-5.3_i386.deb) ...
Unpacking replacement coreutils ...
Setting up coreutils (5.97-5.3) ...
install-info(/usr/share/info/coreutils.iinfo): could not backup /usr/share/info/dir in /var/backups/infodir.bak: Inappropriate ioctl for device
E: Sub-process /usr/bin/dpkg exited unexpectedly
$ df /home/knoppix
Filesystem 1K-blocks Used Available Use% Mounted on
1844472 1529072 315400 83% /KNOPPIX.IMG
$ df /var/backups
Filesystem 1K-blocks Used Available Use% Mounted on
persistent 1844472 1529072 315400 83% /UNIONFS

There seems to be 315 MB of persistent storage available, so I don't understand what workaround I need to implement to finish the package upgrades.

01-24-2008, 08:09 PM
Sometimes this can happen if you have more than one mirror in your /etc/apt/sources.list
I presume you ran apt-get update before the upgrade command?

You may be able to comment out everything in your sources.list and just leave one mirror
then try the upgrade again.
Hope that helps