View Full Version : "Can't find KNOPPIX filesystem, sorry"

05-13-2008, 09:27 PM

Every time I try to boot Knoppix 5.1.1 it says this. I have a Q6600 2.4GHz, 2Gb DDR2, running an IDE DVD burner to load Knoppix. Tried on two other inferior computers, laptop and desktop, with the same burned cd: it works on both. I also tried to load from my IDE CD burner with no difference, so I doubt it's because of the optical drive (the DVD burner is pretty new too).

I tried to unplug all my drives except the CD drive loading the Knoppix CD. Made no difference.

Error comes right after "Enabling dma accelaration: hdi [HD-DT-STDVD RAM G5S..." I'm not too sure about the last part, after "["

Tried every possible cheatcode, most notably "nodma," "atapicd," "failsafe debug -b 3."

Please help, all I need to do is copy my HD (IDE) files to a different HD (USB) so that I can then reinstall Windows so if you ever had the same problem but got it to work with another Linux LiveCD please let me know which one.

Thank you.

05-14-2008, 02:31 AM
I would download a copy of Damn Small Linux and burn it to a CD

Boot it on a different computer and then run the Install to USB drive script and install DSL on a USB thumbdrive.

Then use the USB thumbdrive to boot linux on your PC and copy the files over to your USB hard drive.

This way you can avoid the "DVD drive doesn't seem to work" problem.

05-14-2008, 06:10 PM
Thanks, I tried Ubuntu and it works.