View Full Version : Dependencies?

05-13-2008, 11:00 PM
Please have pity on a beginner! I have Knoppix 5.3.1 installed on my hard drive and things generally are running fine. My problem is that I can't seem to install any new programs. Whether using Kpackage or rpm through root shell, I always get a long list of failed dependencies. The thing is, I am pretty sure some of these dependencies are actually present. For example, I tried to install the Flash plugin for Firefox (I did manage to get Firefox installed and running). among the missing dependencies reported was "/bin/sh is needed by flash-plugin-". That folder is definitely present. I'm downloading the rpm package to /home/username/tmp: does the package need to be in a particular location to be installed?

If this sound too hopelessly clueless, could someone please recommend a good source for such basic information? All of the FAQs, etc. I've looked at, and I have looked at quite a few, just say something like download the package and run rpm -Uvh packagename or some such. I tried installing Yum, as it claims to deal with dependency issues automatically, but the package installer had the same problem with dependencies for Yum itself, so no help there.

Thanks for any help you can give.

05-14-2008, 07:03 PM
Use synaptic package manager to install programs, Knoppix uses debian packages (dpkg). RPM files are for rpm based fistros like Suse and Redhat so its possible you are downloading files for another distribution, not knoppix