View Full Version : 5.3.1 with bootfrom can't mount persistent homedir

07-19-2008, 12:32 AM
I just downloaded the 5.3.1 ISO, burnt a DVD and stored it to the root of my HD for use with an AES256 encrypted homedir I had created with an earlier version of Knoppix (works with 5.1.1 and a few earlier versions). When I boot from the DVD with no parameters (DVD boot), I can enter password and mount the encrypted homedir KNOPPIX.IMG from my USB stick no problem, but when I attempt to do the same thing with bootfrom=/dev/hda2/KNX3.iso, I does not recognize my password for the AES256 image.

I noticed that with version 5.1.1, the hd shows up as /dev/sda2 and the USB is at /dev/sdb1 and now its back to hd at /dev/hda2 with usb at /dev/sda1 as it was in earlier versions of Knoppix. But, whether I use the bootfrom parameter or not with 5.3.1, the usb stick shows up at /dev/sda1, so I don't know why my password would be accepted when I run off the dvd but not when I run off the compressed disk image.

I realize this is a bit odd, but I have confirmed the behaviour a few times.

Thanks in advance....