View Full Version : Knoppix 5.3.1 HDD install boot problems

09-28-2008, 08:11 AM
When Knoppix is booting up, I get an error message that repeats a few thousand times that says
modprobe:FATAL:could not load /lib/modules/ : No such file or directory What does this mean and how do I correct that?

10-05-2008, 01:53 AM
I have tried to load /lib/modules/ and there is no package, also, there seems to be no responses to a lot of questions, so I'm guessing that this forum is not active .... thanks

06-15-2009, 04:23 PM
I don't know if posting will generate any activity on this thread but, here goes. I have the same problem j-mark originally posted: modprobe:FATAL:could not load /lib/modules/ : No such file or directory. I read "somewhere" that it could be resolved by a config file. Knoppix was trying to read the filesystem from the DVD (wrong place after install to hd) or a similar problem. There is no problem after boot up but I want to get rid of the errors.

I can't find the original info (wish I had bookmarked that) but it seems a the fix was simple- comment out one line and be done.
This is my fist post in the Knoppix forum and I hope I get a nibble. Thanks in advance and any help will be appreciated. Tappy

06-15-2009, 07:33 PM
This may not be much help but I did a quick search and that particular error doesn't seem to have been reported here in any other thread. Would this thread (http://www.knoppix.net/forum/viewtopic.php?p=108512) by of any assistance?

06-15-2009, 08:35 PM
Hi Clinton,

Thanks for the reply! I had come across that thread earlier. It's close to this problem but, with a lot more involvement than I want to pursue.
I'm definately a knoppix (and linux) light weight. I help with AIX 5.1 at work but I'm mostly an old VMS guy doing storage and Tivoli TSM.

Again the problem is at boot I receive several lines of the error mentioned above. I read somewhere it was a throw back to an automatic check knoppix did of the CD (file system?) at boot. Either the error was thrown due to looking for the CD (hd install, no longer in cdrom drive) or the file system isn't where the config expects it. I'm still looking and again thanks for your input- I appreciate the help!


06-16-2009, 07:05 AM
Issue with the kernel. If no modules are getting loaded from initrd (image file) the error messages "could not load /lib/modules/" are generated. Comment out the initrd line in /boot/grub/menu.lst

06-16-2009, 04:16 PM
Problem solved! I commented out initrd in /boot/grub/menu.lst and no more errors at boot. Thank you very much nalini for your help!

So now I've set up an HP (Compaq nc6220) laptop dual booting between Knoppix 5.3 and Windows 7 RC via a custom Grub menu.
I downloaded and used GParted (http://gparted.sourceforge.net) to partition my hard drive which worked great.

A big thanks to the members of the Knoppix Forum for the helpful details in their posts. It helped make my first foray in Linux/Open Source
an enjoyable and productive experience. Tappy :D