View Full Version : no3d

Woody Ochs
10-17-2008, 10:38 PM
Evidently this boot parameter, or something like it, can resolve the conflicts which "kdesktop" has with "compiz" in Knoppix 5.3.1 (and they seem to exist with Sidux Ourea also). Yet I can't find anywhere on the Internet any explicit description of the exact manner by which this option is to be passed to Knoppix. On the assumption that "knoppix no3d" is a cheatcode I have entered those characters on the boot line at boot time, but they don't seem to produce any noticable changes to the video boot display, and kdesktop still fails in some one of its variety of ways as before. Does Knoppix 5.3.1 really recognize the characters "knoppix no3d" as a valid cheatcode, or must some other characters or form of entry be used? Could we be looking at some sort of German-English keyboard confusion such as existed back in the Knoppix 3.x era? Also, does anyone know why this incompatibility of kdesktop with compiz manifests itself with different sorts of error displays when booted again and again on exactly the same configurations of hardware and BIOS?

10-19-2008, 04:16 PM
On the assumption that "knoppix no3d" is a cheatcode

yes, it is and it works for me, although I wasn't having any problems with kdesktop failures. I only wanted to turn off the infernal 3D "features" of the KDE desktop. It also has the added benefit that it speeds up the boot process.


Woody Ochs
10-21-2008, 01:40 AM
Thank you for your reply, El Supremo, but that cheatcode "knoppix no3d", does not work on my computers, and again, the failures are not always manifested with the same GUIs. May I add also that to the best of my memory this Knoppix 5.3.1 disk worked fine in each of my computers for some good while after I first started using it, and these failures only began sometime later. This is an extremely strange bug, and because it affects the latest Sidux disk I have to wonder if might not be one of the problems with which the Debian people are wrestling right now.