View Full Version : Knoppix will not boot in DP35DP/E8400 system

12-22-2008, 10:44 PM
I receive the following error when I try to boot to knoppix "could not find filesystem, dropping to a very limited shell"

The knoppix 5.1.1 .iso image was verified through md5sum, burned to CD and booted up and ran fine in an old Dell Dimension desktop, but this CD will not boot up in my current machine:

Intel DP35DP motherboard
Intel E8400 processor
Kingston 1GB PC6400 DDR2 800 memory
Samsung all write DVD drive

This machine boots up fine to Ubuntu 8.10 32 and 64 bit live CD and install, Slackware 12.1 install, Debian 4.0r5 install, Kubuntu 8.04 32 and 64 bit live CD and install, but will not boot to Knoppix 5.1.1 CD or Feather Linux.

I tried disabling one core to see if the dual core was the problem, but I can't figure out why Knoppix is not booting.

Does anyone have a suggestion?

I would really appreciate any help as Knoppix has become my OS of choice above any other Linux distro.

Harry Kuhman
12-22-2008, 11:12 PM
Dual core is not a problem.

There have been some reports of BIOS issues causing the "limited shell" problem with some systems. If there is any BIOS update for this system it wouldn't be a bad idea to try it. But the most common source of the "limited shell" problem seems to be marginal burns, particularly ones done at high speed. If you didn't burn the CD at low speed (such as 4x) I would suggest trying another burn. Another thing you may want to try, if you burnt the disc on write-once media, try it on CD-RW media. The CR-RW media causes the reader to use a different gain setting when reading, and this may cause enough of a change for a disc to boot on you system (assuming there is no BIOS issue).

12-23-2008, 03:49 AM
I downloaded knoppix 5.1.1 again, verified md5sum, burned onto a CD-RW 700MB at 4x (previous was CD-R burned at 11x), rebooted and same problem, knoppix could not find filesystem.

Then I shut down the machine, removed all SATA cables, installed an IDE CD ROM drive I pulled from my old P4 system, rebooted and still get the knoppix can't find filesystem error.

Attempted to update BIOS and intel has made it impossible to update the BIOS on this board without Windows or a floppy (this board does not have a floppy header so why does intel produce floppy BIOS updates for a board with no floppy????), I will never buy another Wintel product again.

Can I use BIOS recovery mode to flash the BIOS? This seems to be my only option unless I can use a linux bios software with the BIOS file, DP0507C.bio, is this possible?

My current BIOS is 0437, the current BIOS for this board 0507.

12-23-2008, 04:33 AM

Flashed BIOS to 0507, problem still persists, so I started modifying BIOS settings and found a solution:

Press F2 at Intel splash screen to enter BIOS, click advanced, click drive configuration, scroll down to ATA/IDE Mode, switch mode from Native to Legacy and this worked for me.

Hope this helps someone.

02-11-2009, 12:19 AM
Hellujuiah..this has happened to me twice, both CD's that were burned and came with books..so can't blame me or the .iso...haven't tried your fix yet but about too....keeping my fingers crossed..