View Full Version : knoppix 5.3.1 slow boot

01-15-2009, 05:46 AM
Dear All

Following this thread "ISO boot from FAT/NTFS/USB"


I have got knoppix 5.3.1 Jap Version CD to boot from its iso image file in a FAT32 Windows XP.

The system boots well but with a very slow start. The boot up messages are:

Welcome to the KNOPPIX.....

Running ..
Total Memory...
Looking for CD&DVD in: /dev/sr0 <---- DVDRAM LED keeps blinking for approx 30 secs

It seems that Knoppix got stuck at probing the "empty" SATA DVDRAM drive on the system for an ISO image file. The drive LED blinks and blinks until timeout and then it moves on and follows the kernel boot option to boot from the iso file at bootfrom=/dev/sda1/boot/knoppix.531/*.iso

I tried several boot options "cheatcodes" to try to stop that but the "probing" continued.

I was just wondering if there is any way to disable the "probing"?

My system configuration is as follows:
Gigabyte EP45-DS3LR
Intel ACHI enabled
SATA Harddisk at SATA0 <-- mapped at /dev/sda1
SATA DVD-RAM LG GH22NS40 at SATA1 <--- mapped at /dev/scd0

If I replace the drive with an IDE DVD drive, it boots up quick. If I replace it with another model LG GH22NS30, it boots up quick as well. So....

Thanks in advance!


01-16-2009, 10:05 AM
The full list of cheat codes are here:

Have you tried

This boots with almost no HW detection, if that works its a matter of going over each HW detection code and
seeing which one causes the problem.

You could also try burning the ISO image on your hard drive to a CDROM and see if you can boot that way.

01-21-2009, 03:37 AM
Dear All

Problem solved.

I edited the linuxrc script in the miniroot to skip the probling of all the bootable devices except /dev/sda1.

It worked!!

Thanks a lot!