View Full Version : "Can't find KNOPPIX filesystem, ..."

02-02-2009, 07:04 AM
I have a Knoppix Light 4.0.2 LiveCD that came with a book I bought called "Hacking Knoppix". When I try to boot from the CD I get to a screen with two penguins at the top that says:

Welcome to the KNOPPIX live Linux-on-DVD

Scanning for USB/Firewire devices... Done
Can't find KNOPPIX filesystem, sorry.
Dropping you to a (very limited) shell.
Press reset button to quit.

Additional builtin commands available:
cat mount umount
insmod rmmod lsmod

If I boot with the command:
knoppix debug -b 3

I get to a # prompt, and everything seems fine. If I 'exit' from this stage, I get the above message about the KNOPPIX filesystem. What am I doing wrong and do you have any suggestions as to how I can fix the problem?

This is not a DVD, but a CD and I am attempting to run it on a Dell Latitude E6500. I am wondering if the hardware in this machine is too new and unkinown to KNOPPIX, yet.

I also just tried to boot it up on my old laptop (Dell Latitude D610) and it got further, it seemed to be finding hardware and the CD, but it finally came up with a blank screen.

Thanks for any and all help.

02-02-2009, 07:22 AM
When booting up on my old laptop (Dell Latitude D610) it gets all the way through to the graphics phase, but I don't see anything on the screen. There is something there because when I switch to the first VC I see on the screen (very briefly) what I think is the KDE desktop. I don't see it long enough to know for sure. I have tried restarting the graphics phase, but it doesn't seem to help.

Any suggestions?

02-02-2009, 10:10 PM
Knoppix 4.0.2 is quite old, and the linux kernel that it came shipped with will not recognise too much hardware, esapecially if you have a sata drive controller.

Try knoppix init 2

This will boot to console, from there you can try
dmesg | grep hd
dmesg | grep sd

this will tell you what hard drives have been detected.

If knoppix 4.0.2 allows, it try knoppix failsafe, which boots with no hardware detectection.
You will be better off downloading knoppix 5.1.1 or Alapha Systems remastered CD of knoppix 5.3.1

02-02-2009, 10:39 PM
I will have to try that and see what I can find out.

Meanwhile, I have some more questions and I was wondering if you could help?

1. Where do I go to find the FAQ that is referred to so that I can hopefully answer some of my questions myself without bothering everyone else? I apologize for being a newbie and not knowing what to do to be more self-sufficient.
2. If I look at the dmesg | grep hd (and sd) commands, what does it all mean? How do I refer to the drives that it finds?
3. How do I find the USB drive that I have put out there and how do I refer to it? I tried /dev/sda1 as I found in some other documentation and that seems to be my hard drive not my USB drive.
4. Did you see my other comment about my D610 computer and no graphics? How do I see the graphics? They are there, but only briefly and I don't know how to see it properly and to interact with it.
5. On the Knoppix site I see a CD iso image for 5.3.1. Why does everyone only refer to 5.1.1, but in special cases (like you said the remastered one from Alapha Systems) only then refer to the 5.3.1 version?
6. Where do I go to get the Alapha Systems remastered version of 5.3.1?

Thanks for the help and sorry about all of the questions.

02-04-2009, 10:51 PM
Ok, most of your questions can be found on google. Start on www.google.com
type in knoppix faq and it returns:


Commands dmesg and grep are linux commands, you can open a terminal and type
man grep
man dmesg
but generally man (short for manual pages) are sometimes quite cryptic and hard to understand,
all you need to know about the command is its searches kernel messages and filters output to just
the hard drives.

Knoppix 5.3.1 is only available DVD, 5.1.1 is CD version but Alpha systems remasteredmknoppix
5.3.1 DVD to become a CD version. There is a link on th remastering section but its here for convenience:


...sorry above link is for vmware you need this link:


The seconditem down is knoppix CD with LCAT acceleration

It defaults to Japanese so booth with lang=uk for english

02-05-2009, 05:03 AM
Ok, here is the latest:

I downloaded and installed the Knoppix 5.1.1 CD version. That seems to be working on my D610 computer. The graphics screen comes up just fine and I can get started using KNOPPIX. Thanks for the heads up on this.

I still have the issue of not finding the KNOPPIX filesystem when I try to boot on my E6500. I was wondering (if it is truly having trouble finding the CD drive) if I could try and create Knoppix on a USB drive and that could possibly help my E6500? Am I just hoping for something that won't work? How do I get the Knoppix system to recognize my CD with the Knoppix filesystem? It can find and read the CD when it boots up to the boot screen, why can't it read it when Knoppix loads further down the line?


02-11-2009, 02:21 AM
I had the exact same problem. File system not found..actually I think it is common now that I am looking for it I see a lot of post for it..anyway this solved it for me:
at the boot: knoppix home = /dev/sda1/knoppix.img

it booted right up...hope this helps.