View Full Version : Knoppix 5.1.1 Incorrectly Detects Monitor

03-17-2009, 10:12 PM
I have been using Knoppix live distros for several years. Suddenly, I can no longer run it from my desktop computer because my monitor (NEC LCD 1860NX) produces an error that the signal is out of range. The video card and monitor are the same ones I have been using for three years. This is a new problem that occurs 100% of the time. I called NEW Tech Support and they recommended that I specify "knoppix display=1024x768" at boot time, but that doesn't help. I also played with the video card's refresh rates - to no avail.

I noticed on bootup that Knoppix thinks I have a monitor that is a different model than my 1860, and I'm not sure how I can override the auto detection and specify to Knoppix that I have an 1860NX. Any suggestions (other than buying a new monitor)?



03-19-2009, 08:18 PM
I have come to the conclusion that this monitor might be bad. The Knoppix hardware auto-detect thinks it is an NEC65e8 (whatever that might be, NEC Tech Support didn't know). None of the cheat codes work (display=, xvrefresh=, xhrefresh=, hsync=, vsync=), but the monitor works fine with Windows XP. This sort of problem will probably ensure that MS will control the desktop market forever. Oh well ...


04-20-2009, 08:26 PM
I have a 2nd machine on which I have installed Open SuSE 11.1, and it correctly detects and identifies the monitor. Apparently, the problem has something to do with Knoppix 5.1.1 booting from a thumb drive and putting my video into a mode that the monitor can't handle. I have tried all the possible bootup "cheats" that I know about, to no avail.

Does anybody have any ideas about this? I was able to use this Knoppix image about six or seven months ago, and I wou;d really like to be able to use it again.


05-03-2009, 11:48 AM
I have seen many things like this.
1. if you have an ATI rage video card, you have to say so: xmodule=r128
2. vsync can act odd; sometimes vsync=61 works, but 60 or 70 fail.
3. try lots of values of screen= with each vsync=; always use both.
With my wide LCD screen, only 1280x768 worked; any other settings gave me 800x600.
You often get something other than what you ask for; some drivers don't go over 1280x1024 at least for me.
If all else fails, you may have to remaster giving x.org no choices but the ones your monitor says it supports. This worked for me with a very old Dell LCD.
All my LCDs say bad signal for an interlaced mode. If you have a CRT that will take interlacing and report its mode, you can use it to find a setting to try.

05-03-2009, 07:44 PM
I tried all of the combinations of vsync, hsync, etc. Sometimes I would get no signal at all detected by the monitor, sometimes it would be out of range. I think that the video card is an NVIDIA GeForce 7600 GS. What is most perplexing to me is that I used this same desktop computer to install and test Knoppix 5.1.1 onto a bootable flash drive last summer, and the only thing that has changed since then is the replacement of the power supply. Everything else works fine. I can play games and video clips in Windows, but I can't run Knoppix from my flash drive. I have booted this image onto a different machine using the same monitor, and I have used the reported monitor settings on my primary machine to no avail.

When I originally set up my Knoppix persistent image, I had the resolution set to 1024x768, but it seems to make no difference what values I specify at boot time - I still can't get the monitor to work. Do you suppose that there might be something very minor wrong with my video card - something that might have been related to the failure of the power supply? Something that doesn't bother Windows, but that Knoppix can't tolerate? I have just about given up on this issue.

Thanks for your help and advice.


05-09-2009, 07:32 AM
I have exactly the same problem with Knoppix 6.1.
My machine:
CPU: Athlon 64 64 x 2 5000+
Video chip: nVidia GEforce 7050PV / nVidia nForce 630a integrated on MSI motherboard
Monitor: Benq FP73G, refresh rate: 56 - 76 Hz, native resolution 1280 x 1024
Dual boot: OpenSuSE 11.0 plus Ubuntu 8.10 Intrepid.
Both use a proprietary nVidia driver running at 1280 x 1024 resolution
with a 60.02 Hz refresh rate
PuppyLinux also runs perfectly under the same conditions.

When I boot Knoppix 6.1, however, things work fine till the system goes to level 5, then the monitor
displays an "out of range" warning. I have tried booting with "knoppix screen=" at various resolutions,
as well as defining various horizontal and vertical refresh rates, nothing makes any

I can open a new terminal in text mode (ctrl + alt + F1). if I enter here "xrandr -q" I get
the message "can't open screen". The X-server doesn't seem to be running at all.

I have read Klaus's answer to a somewhat similar problem in Linux Magazine issue #103.
This is of no help because the system doesn't even start at low resolution.

Actually I'm not all that worried because Ubuntu and OpenSuSE are running smoothly.
However, it seems a shame to give up on Knoppix altogether.

05-11-2009, 06:23 PM
Sounds like a bug. I'm just going to give up on Knoppix.


05-12-2009, 07:06 AM
don't blame you, deesy58.

By the way, this forum seems strangely quiet compared to the forums I usually work with

05-12-2009, 07:05 PM
When I originally set up my Knoppix persistent image, I had the resolution set to 1024x768, but it seems to make no difference what values I specify at boot time - I still can't get the monitor to work.

Have you tried NOT loading the image (hit cancel or escape)?
The image has Xorg.conf file (IIRC) that may override the screen=

If this helps, you may have to mount the image and delete some settings files.
I think also that K511 persistent images often got corrupted due to some kernel bug.
If yours is good, keep a backup.

05-12-2009, 07:12 PM
Hmm. I'll try that!

What is so puzzling is that this image used to load fine on my machine, and it still loads fine on three other machines that I have tried it on.