View Full Version : Won't Boot - Minimal Shell - Keyboard Stops Working

04-28-2009, 02:17 AM
Hello. I am trying to boot from a Knoppix 4 CD to save files from an XP harddrive that crashed. I am getting the dreaded "can't find knoppix filesystem, sorry" message. I have tried several cheat codes including:

knoppix nodma
knoppix noapic acpi=off
knoppix vga=0
knoppix acpi=off pnpbios=off noapic noapm
knoppix vga=0 debug -b 3
failsafe debug -b 3

None of them are able to allowing the boot from cd. And if given a command prompt (like during a failsafe boot, or minimal shell prompt), the keyboard (Dell USB) won't work for typing any commands.

I have seen similar forum posts, but I couldnt find any solutions that work for my issue. I have used this Knoppix CD on many other Dell computers and I just tested it on my laptop and it worked. The problematic machine is Dell Optiplex 755 (the ultra small form factor).

Would a newest version of Knoppix be more likely to boot on this newer machine? Also, the computer only has USB ports, so if the keyboard is the problem, switching to a PS2 keyboard is not an option.

Any help would be appreciated. I would love to boot into linux and save some files from the harddrive. Thank you in advance.

Harry Kuhman
04-28-2009, 04:36 AM
I don't expect an cheat code will fix this. Did you burn the disc at a low speed? The most common cause of this problem is trouble reading the disc, and the most common cause of that is a high speed burn.

I can't rule out a newer version helping (particularly if you burn it slowly). But to really answer that question it would help to have good details about the hardware that you are booting on and the version that you are trying to boot. About the only old version issue that comes to mind at the moment is trying to boot a very old version of Knopiix without SATA support on an optical drive with an SATA interface. There may well be others, but that is the only one that comes to mind.

04-28-2009, 12:53 PM
Try to set the SATA-Mode in your BIOS-Setup to AHCI. It should actually be set to Legacy IDE or Native IDE and in this way the error occurs.

Additional: Most of your tries like failsafe supress the load of "usb-drivers" (uhci, ehci, udev) so the keyboard can't work. Use a PS2-one for this (it has to work, otherwise your hardware is faulty).

Ooh, i read too fast. You have no PS2- port! So you have to load the usb-modules manually. But first simply try my first hint and boot knoppix the normal way without any options.

04-29-2009, 07:15 PM
I downloaded Knoppix 6.0.1 and sucessfully booted from a flash drive. I believe the older version I was using (Knoppix 4.1 I believe) had an issue with the SATA interface, like you suggested. Thanks.