View Full Version : Getting error 15 when trying to start up knoppix from grub

05-22-2009, 07:38 AM
I have two hard drives on my computer, one running Vista and Ubuntu both of which load from the grub boot screen. The other hard drive I have loaded Knoppix onto, my problem is that I can't load the Knoppix from the grub loader, it is listed but comes up with an Error 15 can't find file, I believe this is a registry error.
The boot/grub/menu.lst , shows
root (hd0,1)
kernal /boot/vmlinuz root=/dev/hda2 lang=us apm=power-off vga=791 nomce loglevel=0 quiet rw

title Windows
rootnoverify (hd1,0)
chainloader +1

The device.map only shows
(hd0) /dev/sda

I tried the fdisk through a terminal in Ubuntu which showed the Knoppix to be on dev/sdb2.?
I am still new to this and am not sure how I can correct this, I assume that I have to edit the device map and possibly the menu.lst but I am unsure how as they seem to be locked to all attempts to alteration?

05-22-2009, 08:41 AM
boot from CD then.

In a terminal do

Now you have full root privileges.

at the root@(hostname) $ prompt

cd /media

mount /sdb2
Mounts the drive Ubuntu is identifying as /sdb2, but default is read only so


mount -n -o remount,rw sdb2

now you have it in read-write mode and with root prvileges.


cd sdb2/boot/grub

then cp menu.lst /home/yourusername

That copies the list to a directory you have write privileges for even in X... like KDE, which is kind of flakey about that.

close the terminal.

Browse to the /home/yourusername open the file

and edit it.

Save it.

Open a terminal again,


you're automatically starting from your /home directory

cp menu.lst /media/sdb2/boot/grub

you'll be asked if you want to overwrite

say yes.

one of the things to edit out is the quiet parameter.

It'll give you a glimpse of everything up to the kernel panic line. as you're booting next time.

Do the same thing for device.map in the /partition/boot/grub directory that you actually boot from.

My guess is you didn't reinstall grub when you installed Knoppix.

So it's still using the old device map.

You just didn't have write priveleges on the drive with Ubuntu.

And its grub files like device maps.

If your editor is in KDE you'll probably still not have write priveleges to it, but from the terminal you can.

mc has a built-in text editor as well, and if you're doing this as root you can save the new file with no qestions

to get to mc (midnight commander) just type


If you already knew that part, don't be alarmed.

Lots of new people don't.

Another workaround is to log in as root to begin with.

KDE in knoppix doesn't let you BUT you can opt for "console login"

drops you to a shell, login, password, then


Then you'll have the full graphics interface with full root privilege.

05-22-2009, 03:03 PM
That will give you some specific messages right at the point where it fails to boot.