View Full Version : Mounting a HD and file system error

07-03-2009, 08:40 PM
Hi there,
Apologies in advance if my post seems kind of repeated, but I tried several other things I saw in other threads.
My experience with Linux is not that good.

I have an external HD, WD800 with 80 GB of capacity. Everytime I connect it to Windows it asks me to format it. I tried to run CHKDSK and it said the file system is RAW.
When I tried to mount it on Linux, it said "I could not mount the drive.....the file system is not specified"

Any suggestions on how to work on that problem??
I would really appreciate your help.
Thank you.

Harry Kuhman
07-03-2009, 09:03 PM
You don't actually say it, but your post seems to imply that you think that you have data out there on that disk that you would like to recover.

If that is the case, look at the man pages for gpart and testdisk. gpart is the tool that I would recommend, it can examine a disk where Windows has destroyed the partition table and recreate it based on the actual data it finds on the disk. It sounds like you partition table is missing. Please note that it isn't a cure for everything and that if windows has damaged the actual data on the partition (as it often does) then it is not going to fix that. But it can recover a partition table.

I think of testdisk as gpart for dummies. it does a few other things, but in this case it would hopefully do a partition recovery similar to gpart. But you have less control than with gpart, so I suggest lookat at gpart first.

07-03-2009, 09:37 PM
Yes Harry,, how dumb of me to forget,,
yes am trying to recover the data..
I googled the GPART and i download it, seemed like a 46 KB file,, so how should i use it??

Harry Kuhman
07-03-2009, 10:27 PM
Yes Harry,, how dumb of me to forget,,
yes am trying to recover the data..
I googled the GPART and i download it, seemed like a 46 KB file,, so how should i use it??
I'm not clear on the downloading issue at all. You should not have had to download it, all versions of Knoppix at least up to 5.3.1 included it. I'm pretty unimpressed by the 6.x versions, and a lot of stuff seems to have been stripped out. I don;t know if gpart was stripped out or not. If it is not already in your version of Knoppix, I would suggest that you might want to grab a 5.x version of Knoppix, either CD or DVD or both, while you still can. gpart will be included and you will not have to worry about installing it. Plus you'll get lots of other good stuff that is missing in 6.x. And since the 5.x versions will eventually be taken off the mirrors as newer versions come out, getting a good version now isn't such a bad idea.

To run it, open a shell. Before you run it, type man gpart at the prompt (or read the map pages for it on the Internet). This documentation gives you all of the options and switches to type in to point it at the right hard drive and tell it to analyze the drive. It will examine the drive and print out what it thinks the partition table should be. You should look that over and see if it makes sense. For example if you know that you had two physical partitions out there but it thinks you only had one, do not let it write a partition table, or if the partition sizes don't make sense, don't let it write the partition table. If you do like what it sees, then look at the man pages again and find the additional switch to include on the command line that tells it to write the partition table, it will run again, figure out the partition table again, and this time put it back on the drive where God wants it. I don't have a running copy in front of me at the moment, so I'm leaving it to you to actually read the documentation and find the switches you need. And feel free to play around a little and try running it different ways, as long as you don't give it the switch to rewrite the partition table then you can examine the disk to your heart's content without changing anything.

Once it runs, you then have some choices about what to do next. You could examine the disk with Knoppix (mounting can be a pain with 6.x versions but if you are running 5.x versions just reboot and the partition icons should show up on the desktop). From there you can see if you can read your files. What to do with them is a different matter. My choice of recovery techniques is to transfer them to another computer on the local network. I install an FTP server on a Windows box and use Konquror under Knoppix as the FTP client to transfer the files. I find this faster and cleaner than fighting with networking a Windows and a Linux box together for file sharing, which has sometimes worked flawlessly for me and other times been a complete nightmare. Other options include moving the file that you want to another hard disk or to a flash drive, but if you use another hard disk I strongly suggest that it should not be a NTFS partitioned disk. FAT formatted drives are fine, but Knoppix does not play well with NTFS drives and you risk further recovery issues if you do. You might even want to put the drive with the recovered partition table back into a Windows box and see if Windows can't get your files. But since windows likely just destroyed your files you very well may be wiser to recover with Knoppix and make some backups before trusting Windows again.

07-05-2009, 12:03 AM
I couldn't find my way with GPART, I mean I didn't know how to use it..
I tried running the mount command:

mount -t ntfs /dev/sdb1 mnt/sdb1
and gave this messgae:

NTFS signature is missing.

One more thing,, when I issued the fdisk -l command,
it showed the following info:

Start: 1 End: 9730 Blocks: 78148608 System: FAT16

Any idea?