View Full Version : udevadm settle hangs in PCI section

07-07-2009, 11:20 PM
Hi all,

First a brief summary. I had a CentOS working system with 6 harddisks RAID 5 in a SCSI controller. There was a problem which I thought at that time was due to the hard disk failure (two disks) that caused the system to crash. Now I am using only 4 hard disks in the RAID 5 set up and I have reinstalled the operating system. I am also able to access the Hardware RAID Controller's utilities during the system bootup time. However the issue I am facing now is that the system refuses to boot up and hangs in 'Starting udev'. I tried using a knoppix live CD and after some permutations, found that the problem is in the 'udevadm settle' command which hangs indefinitely while waiting for the PCI bus (I tried adding a timeout in the udevadm settle command but that didn't help).

So I have two questions:
i) If really some PCI controller is bad most probably the SCSI one, is it possible to figure out which one it is? (Note: i find it very suprising that if the PCI controller was bad, the RAID utilities do work fine and I am able to create RAID arrays etc.) My guess is that one of the ports of the SCSI controller is bad so as long as that port is not accessed the RAID utilities work fine.
ii) Is it possible to get the system to boot past the bad hardware *somehow*? (I have tried the pci=bios and pci=biosirq options and it didnt work)

Thanks a lot in advance!