View Full Version : Bootup hanging after scanning for hard disk partitions?

07-27-2009, 01:16 AM
My mothers old (~8-9y/o) Dell stopped booting one day. She's resigned to getting a new computer but wants to recover some data from the hard drive (she brought it to the geek squad at best buy and after paying them 90 bucks, they said they couldn't do anything).. so i thought I'd give it a shot.

I'm trying to boot an old version of Knoppix (had the CD from recovering data from corrupted HD a few years ago) and it boots up fine until

"Scanning for Harddisk partitions and creating /etc/fstab... Done"

then it just hangs... can anyone tell me what is supposed to happen after this? Are there any cheats i can use to bypass this next step to see if the bootup will proceed?

If it matters, my mom simply said 'it wont boot up' and when I first went into setup (F2 after the bios screen) there was no HD detected.. but for some reason (i think after i tried to load knoppix) the C drive now shows up (windows still wont bootup though). Recover Console also doesn't work.. it hangs at some point while booting.

thanks for any thoughts on how to proceed!

Harry Kuhman
07-27-2009, 01:26 AM
Knoppix doesn't care if there is a hard drive or not, it should boot without one. I don't know the particular issue that is keeping the system in question from booting, but you very likely need one or more "cheat codes" to boot. See the cheat code documentation that you should have got when you downloaded Knoppix, or follow the documentation link near the top of this page and read the cheat codes section of the wiki. You might also want to try typing in expert at the boot prompt (not knoppix expert) and boot in expert mode. You will not like running in expert mode, as many things incluing the network and likely even the mouse will not work, but booting in expert mode a few times may give you insight on where Knoppix is hanging, and then it will be easier to find the right cheat code to get past it.

Good luck. Since the computer was taken to geek squad, I hope that you have the same hard drive in there that was in originally, but I wouldn't bet on that!

07-27-2009, 06:22 PM
I've tried booting in both failsafe and expert modes, but both hang.

In the expert mode, it gets to a point where it says "Interactive Configuration finished. Everthing else should be fine for now", then it proceeds to: "Scanning for Harddisk partitions and creating /etc/fstab... Done" where it hangs.

So what happens after /etc/fstab is created?

Any idea on how to troubleshoot further on this?