View Full Version : net problems booting PXE

08-13-2009, 12:28 PM
I try to make knoppix boot via PXE.
I use knoppix version 5.3.1 (I have not enough traffic to dl lastest DVD being unsure it can help).
I tried to read this: http://www.knoppix.net/wiki/KNOPPIX_Terminal_Server and some other docs,
but i use NFS.
My problem that kernel can't find network modules during boot:
can't cd to /modules/net
ip: cannot find device "eth0"
ip: cannot find device "eth1"
ip: cannot find device "eth2"
ip: cannot find device "eth3"

I think problem is in rootfs file called "minirt.gz" I use as initrd=/knoppix/minirt.gz
I found this file in /cdrom/KNOPPIX/boot/isolinux/minirt.gz
I couldn't find any file called "miniroot.gz"

So I need help: where can I find proper rootfs for PXE boot or what can I do with network drivers in minirt.gz?
I tried to mount it as: "gunzip minirt.gz ; mount -o loop minirt /mnt", but have a message about wrong fs type.

08-13-2009, 03:02 PM
Well, I found this: http://www.knoppix.net/wiki/Knoppix_Remastering_Howto#For_5.3.1_the_file_syste m_in_minirt_changed_to_ramfs.
# In the temp directory do the following:
cpio -ivu --no-absolute-filenames < ../minirt
# You should now have the minirt directory tree under minirtdir . Make your mods to files.
# To wrap it backup up, in minirtdir:
find . | cpio -oH newc | gzip -9 > ../minirt.gz

It works, but manually copiyng /modules/net/*, hacking linuxrc to load that files and repacking fs is not too good.
Would be better to find easier way for PXE boot.

08-24-2009, 01:11 PM
well, I tried version 5.1.1 and lastest version too.
There were the same problems.

I don't want to try that with knoppix - i took OpenSUSE linux, rebuilt kernel, rsynced rootfs, hacked initscripts and now i'm fine. My suse works in rescue mode instead of knoppix.