View Full Version : Cannot write to USB

09-07-2009, 03:23 AM

I just installed Knoppix 5.1 persistent install on USB device (sda1). Everything works fine except I cannot change permissions to read/write for the USB device.

I searched internet and first tried to edit fstab. That did not work as Knoppix seems to automatically add entry to fstab upon boot. So, next I right click sda1 icon on desktop and changed persmissions for Group and Others to Read & Write. I also checked off "Is executable" per instructions on internet. Then I next unchecked "read only" after clicking on Device tab.

Finally, I right click device and and changed to Read/Write Mode. I then clicked ok on next screen. I still could not write to device, and a mount command revealed it was still mounted as read only.

I search some more on the internet and am told to issue the following command:

sudo mount -t vfat /dev/sda1 /mnt/cdrom -o remount,rw,users,umask=000

This seemed to work as mount command revealed all devices now read write. However, I have the same problem as I still get access denied when I try to write to device. Clicking change read/write mode prompts Knoppix to ask are you sure you want to change to read only? So, system seems to think it read/write also. The owner of sda1 is Knoppix, if that helps.

Please can someone help me? There is no working hard drive in this computer, only flash drive and CD-RW drive. I just need to boot into Knoppix, use Open Office Calc to do my homework for school, and save spreadsheets to USB to bring to school.

I know there has to be a way to do this even if Knoppix by default boots into read only. There has to be a way to change it. I am new to Knoppix but not totally new to linux.


09-07-2009, 03:32 AM
One more thing: the mount point of sda1 is /cdrom. Forgot to mention that even though it is what Knoppix assign by default.

Also, I do not have partitions created on flash drive. Everything is in the root of sda1. Could that be part of problem? Maybe I need to make seperate partition to make read/write?

Thanks again.