View Full Version : Knoppix on Gecko EduBook

09-10-2009, 03:35 AM
I have a Gecko EduBook made by NorhTec in Taiwan on which I am having significant problems getting Knoppix booted.

If just allowed to boot normally, it works until Tux shows and then nothing happens (forever).

I have tried all of the suggested Tips & Tricks on the Cheat Code page, but still end up with a locked up unit. The best result to date has been using

knoppix pci=biosirq vga=0 debug -b 3

which shows a lot of messages but then apparently switches video mode at which point the screen goes blank and nothing more happens. I have been trying to determine what is the last shown message, but it does not display for very long.

The hardware appears to be somewhat "interesting". According to the NorhTec web page, the processor is a Xcore86 (Vortex86 MX). Internally, it has two SD card slots, which are commonly used as the bootable media and storage. The unit I have has the internal IDE interface connector populated, and I have been attempting to use this to connect a conventional laptop hard drive, onto which I could install some Linux distro. Grub happily booted from a hard drive set-up on a different PC, so I know the interface is working.

I have been booting Knoppix from a USB connected DVD drive, using the 6.01 CD-ROM.

The unit can be supplied with Puppy Linux, and the company has demonstrated that Windows XP can run on the hardware. The demonstration Windows XP SD card I have from the manufacturer boots and Device Manager identifies some of the hardware.

The video adapter is identified as being a "D1010 VGA(R2)", using drivers that are from a company called RDC Technology Inc. It uses interrupt 14 (which surprised me). Video resolution is 1024 x 600.

The network card is identified as being a RDC PCI Fast Ethernet, using drivers that are from a company called RDC Semiconductor, Inc. It uses interrupt 3.

The IDE controller is identified as being an "Intel 82801EB Ultra ATA Storage Controllers - 24DB", using interrupt 11.

The sound controller is identified as Realtek High Definition Audio.

It has 4 USB ports (one internal), and the Windows Device manager lists two "Standard Enhanced PCI to USB Host Controller" entries (using interrupts 5 and 9) and two "Standard OpenHCD USB Host Controller" entries (using interrupts 4 and 7).

Is there any way I can stop the (apparent) video mode switch (which appears to be the main thing that causes everything to stop), such that I can get to a shell prompt and at least probe the hardware in some way?

Better yet, does anyone have any suggestions on boot options that will allow me to actually get Knoppix running "fully"?

Any suggestions would be appreciated.

Harry Kuhman
09-10-2009, 03:54 AM
....Is there any way I can stop the (apparent) video mode switch (which appears to be the main thing that causes everything to stop), such that I can get to a shell prompt and at least probe the hardware in some way?

Better yet, ......
You should be able to get Knoppix to boot into a text mode shell by typing knoppix 2 at the boot prompt. Or hit F2 or F3 and look over some of the other options (you can still type knoppix 2 at that point). Sorry, I don't know your hardware to help beyond that, but you have posted good data for others to go on, hopefully it will enable some one else to give you the information that you need.

09-10-2009, 04:31 AM
You should be able to get Knoppix to boot into a text mode shell by typing knoppix 2 at the boot prompt.

Hi Harry,
That got me no further - Tux just sits happily waiting for the second coming. I expanded the line to

knoppix debug acpi=off pnpbios=off vga=normal pc=bios nohwsetup 2

and, while this now displayed the stream of messages, the same "blocks of colour" appears over the bottom of the screen immediately followed by clear screen and then nothing. I guess this could be some manner of a "reset" that goes nowhere...

The last line that either myself or another engineer here were able to observe was saying something about a scheduler.

Is there any way to freeze the processing - i.e. to stall the stream of lines going past such that we have some hope of getting closer to knowing roughly where the "crash" is occurring?

Harry Kuhman
09-10-2009, 04:43 AM
Try typing expert at the boot prompt. If the problem is before the last question in expert mode booting you should see what you are looking for. If it is after that it may still get past you, but you may be able to play around with the answers in the exert boot process and make a difference.

09-10-2009, 05:07 AM
Try typing expert at the boot prompt.
That's strange - it doesn't have the kernels expert, expert26, debug or knoppix-txt. However, it does have the kernels memtest and failsafe.

Possibly of interest, memtest seems to run fine...

I have just had some better success with

knoppix debug 2

It doesn't boot - there is a kernel panic reported, but it also doesn't clear the screen. However, the first part of the dump is well off the screen. I am seeing if there is any way I can capture what happens higher up.

09-10-2009, 07:34 AM
I have just had some better success with

knoppix debug 2

It doesn't boot - there is a kernel panic reported, but it also doesn't clear the screen.
As much of the dump as I can see reports the following. (Delta times are omitted)

Call Trace:
[<c010fbf0>] 0xc010fbf0
[<c01106d7>] 0xc01106d7
[<c0102a19>] 0xc0102a19
[<c05ac739>] 0xc05ac739
Code: Bad EIP value.
EIP: [<00002076>] SS:ESP 0068:c05a7f68
---[ end trace a7919e7f17c0a725 ]---
Kernel panic - not syncing: Attempted to kill the idle task!
------------[ cut here ]------------
WARNING: at kernel/smp.c:333 ()
Modules linked in:
Pid: 0, comm: swapper Tainted: G D #8
Call Trace:

Unfortunately, all this is on the end of about three pages of data that tear by in about one tenth of a second (I'm not kidding, I attempted to video it).

A bit of research on the 'net implies that interrupts were disabled at the time that the SMP test was done, which led to the kernel panic. Unfortunately, the unit has no serial ports, so I can't capture any more of the output.

09-11-2009, 02:12 AM
Following the advice of a friend, I have had some success in NetBSD - the system boots into X. However, the screen size (1024x600) is not "appreciated" by the video driver, and it uses 168 lines of pixels that do not exist, making KDE "interesting".

However, that is besides the point.

What is of interest is the fact that some readily-available BSD derivative does (at least partially) understand the hardware - sufficiently at least to allow the system to boot without a kernel panic. Accordingly, it may be possible that I can derive some information that may help get Knoppix running.

Does anyone know enough about both BSD and Knoppix to be able to walk me through how to discover what I need in order to "assist" Knoppix in booting?

kevin bowers
11-12-2009, 03:17 AM
I had the exact same problem booting Damn Small Linux on my new Gecko. Get into your BIOS setup and change the USB speed setting. The options are "high speed" or "full speed"; I think I had use "full". DSL can't find either the sound card or the Wi-Fi. So far no Linux distro I've tried will. Please let me know if you find one that will; I'm about to try to configure Puppy Linux to compile the drivers supplied with the unit. Good luck!

11-12-2009, 03:30 AM
Thanks for your feedback. One of the Linux gurus at my work has had some better success than I, but I have not yet had time to extract the details from him. However, I believe that he used the drivers supplied by the manufacturer.

Apparently, the manufacturer has working images for a few different distros. I will see what I can find out, and will post it here.

11-14-2009, 02:17 AM
I have been able to get Knoppix 5.1.1 to work. However, I have not been able to get it to use the display at 1024x600, so much of the screen of out of reach.
Maybe there is a special hack to make it do that.

I have been able to get Debian testing, Squeeze, to load and it is working OK. However, the firmware loading for my usb wireless is
broken, and no sound card is recognized. Other than that the system is quite stable. Norhtec states they got Debian 5.0 to load,
but I have had no success, trying various boot parameters. The boot kernel of the install stops with a kernel panic, and again
several pages of info fly by before the system goes dead:(

I also tried several other distros that the Norhtec website mentioned but with no success--something always breaks before
the process is completed. I suspect that special boot parameters were used to get these to work.

I have an e-mail into Norhtec on what boot parameters they set to get Debian 5.0 to work. The usb wireless key does work
under Debian 5.0. In time, Debian Squeeze should have wireless firmware loading fixed, and perhaps sound will work,
but the sound on this computer is a bit off the "beaten path" If I hear anything back, I'll post it on this thread.

11-14-2009, 03:18 AM
After my prior post I did a search for "cheat codes" and "knoppix" and using

knoppix screen=1024x600 desktop=icewm

I got a boot into a workable setup. KDE is really too heavy duty for the CPU in this netbook. However,
there is now the ability to get in and do rescue work should some other install attempt go awry.

kevin bowers
11-15-2009, 01:36 AM
Michael Barnes, Norhtec CEO, has been very helpful. He sent me a link to a kernel image file that should work with either Debian or WattOS:
Username : anonymous
password : anonymous
Note this is an ftp server, not HTTP; the image file is in the /shared directory in .deb format. Mr. Barnes indicated that the way to install it is to boot a host computer to the live CD, use it to install the distro (we were specifically talking about WattOS) to an 8GB SD card, boot that computer to the SD card, and install the kernel image (.deb file), then install the card in the Gecko and boot to it. I've been installing directly from an external CDROM.

It finally occurred to me to ask, and it seems that Nortec also sells SD cards with workable installations of both WattOS and Puppy Linux already installed, and at very reasonable prices. I've ordered one of each. I'll keep you posted.

Here's a thought for someone with more time that I have: could you find a Knoppix release with kernel 2.6.30, and tweak it with the same new kernel? Then try it in the Gecko? It's been many years but Knoppix used to have issues when installed to HD. Nobody back then thought we'd be running OSs from flash drives, they were 2 megabytes not 8GB and way too slow. Better to run DOS from floppy!

Luck to all,

Kevin Bowers

11-17-2009, 01:08 AM
Yes, agree, Norhtec has been quite helpful. I got the same IP address and have tried the kernel under both
Lenny (current stable) and Squeeze(current testing). Over the weekend I found a way to upgrade the
Lenny kernel (2.6.26...) to the 2.6.30... kernel from backports. However, in both cases the kernel
from Norhtec failed with a general protection fault during bootup . So I downloaded the stock 2.6.30
kernel source from kernel.org, used the config from the Norhtec kernel, and then recompiled on the Edubook--
it took about 2.5 hours--not bad for a quite limited CPU! However, that kernel also had a general protection
fault at the same point. They all happen just after swap is initialized. Based on the traceback, the kernel
was trying to access the BIOS with: __apm_bios_call+0x75/0xf0.

The Debian backports kernel and the Squeeze kernal both asserted that the Edubook had neither APM nor
ACPI support. Perhaps the APM modules are compiled in? My next step is to look at the config of the
kernel and disable any attempt to check the BIOS for APM. My machine at least, shows no hint
of any APM or ACPI in the BIOS setup. Is there a BIOS update available from the maker of the
Vortex86MX board? I would like to have some way of monitoring the state of the battery in the

Also neither Debian installs are able to load the firmware for the Airlink 101 wireless USB stick I
have. The stick works fine on two other computers with Lenny with either 2.6.26... or 2.6.30...
So I suspect something in the detail of the Edubook hardware is the source of the failure.

kevin bowers
11-21-2009, 03:41 AM
I don't see any reference to ACPI or APM in the BIOS, either, but Windows XP reports that the computer is APM compliant. However, the tooltip associated with the tray icon for the battery always reports 85%, whether it's fully charged or after the "low battery" warning balloon pops up. Sure would be nice to have a plain old voltmeter, but unfortunately these days most people don't know a volt from a velocipede.

I haven't even gotten an order confirmation on the SD cards with Linux installed, maybe I got lost in their e-paper mill. I've sent them another request-to-order.

kevin bowers
12-05-2009, 04:09 AM
Just a quick update:

Took a lot of work, but the WattOS image Norhtec has on their server can be installed in the Gecko Edubook with Clonezilla. I found Clonezilla a bit confusing but eventually had a working WattOS beta 2 installation. The sound even worked--but not the wi-fi. Another round of e-mails with Norhtec and I wound up compiling a downloaded driver for the new updated wi-fi dongle--almost exactly 24 hours before the cards with the 2 OSs installed arrived.

Since I already have a WattOS system installed I haven't even tried that card, I assume it works. The Puppy Linux card, however, still won't work either sound or wi-fi. It's version 4.2.1, which has lots of fancy window-dressing and is probably the prettiest desktop I've ever seen, but still not fully functional on this machine. Norhtec says they're trying to get an Edubook to Barry Kauler (Puppy founder) so perhaps he can tweak it around; I hope so since I'm a Puppy fan.

Anyone had any more luck with Knoppix? From what I've seen so far it's probably too heavy a distro for the Edubook. Most of the apps I've tried won't play an mp3 without "skipping"; only one, SMPlayer, does well enough to listen to. The CPU "meter" stays pegged all the time it's playing; even moving the mouse causes skipping.

Happy computing,