View Full Version : wlanctl-ng: Operation not supported on linksys WPC11 v3.0

06-06-2003, 07:43 AM
I have a linksys WPC11 v3.0 card which is driver compatable with v2 and 2.5 cards IIRC and i get an Operation not permitted when i try to use it with kismet or airsnort. Either im missing something terribly obvious or dunno what im doing.
Does knoppix have all the necessary drivers in it to put this card into promiscuous mode?

I've tried kismet with prism2, prism2_pcap and prism2_hostap (never heard of that one) and all fail.
I've also tried to do it manually useing wlanctl-ng since airsnort returns the same error.

I'm useing knoppix 05/20

06-06-2003, 09:28 AM
That's because you have to run it as root and not as knoppix.

Open a shell window and type
sudo su
and then manually launch the program from the command line.

06-06-2003, 03:01 PM
Heh yea im not that new.

root@ttyp0[root]# airsnort
wlanctl-ng: Operation not supported

06-08-2003, 01:33 AM
Oh yea, when i try to change its mode manually for airsnort, it says theres a version conflict between the drivers and the software or something like that.

06-11-2003, 08:52 AM
Awh crap now i see whats wrong, I have to use the Orinoco_cs as the card type even tho my card is infact a Prism. some how that strikes me as non-intuitive.

It did manage to make me feel like a newbie tho.

10-23-2003, 11:17 PM
I have same problem with airsnort (not tried kismet)
i have senao 2511

Network device: eth0
Card type:
prism2 - i get 2 wlanctl-ng: Operation not supported, and "could not set monitor mode"
orinoco - i just get could not set monitor mode

any ideas?
thanks :oops:

10-25-2003, 02:56 AM
for normal use (ie surfing) it works fine, does that mean it's for sure an incompatibility with airsnort or what?

04-06-2004, 08:35 PM
Hey Im really a newbie on Linux and the wireless thing.

I want to get a SENAO/ENGENIUS 2511 EXT-2 (Prims 2.5 chipset)

but I want to know if this will work with Airsnort.?