View Full Version : Unable to mount Vista HD, Help!

10-14-2009, 01:22 AM
I have Dell Inspiron laptop running Vista 32 that crashed about 2 months ago. I'm not sure why it crashed, but it gave me trouble after trying to install a printer driver. Then one day it ran a chkdsk on startup, and never booted again. It won't boot in safe mode, and none of the startup repair or system restore points worked. All I have left is restore factory settings, but I'm trying to extract my data before I do that.

I'm a smart girl, but I don't do code. I'm learning what I can, but the Knoppix Live 6 comes up with an error, "unable to mount device", when I try to access my HD files (wanting to copy them to another hard drive). I've looked up trying to force it to mount the drive, which brings me into using code... I've tried:

su root

and I'm told no such file or directory exists. (Same with sda1, but it looks like my drive comes up as sda3). I've tried:

su root
mount -t ntfs-3g /dev/sda1 /media/sda1 -o force (and -0 and -O, since I couldn't tell what that was)

and a help tutorial of commands appears.

So, since my brain has absorbed as much as I can force it to at the moment, could someone please tell me, 1) am I doing something wrong? 2)is there something else (like Ultimate Boot CD, which I've created but don't know how to use) I should try? or 3) can I be put out of my misery and accept that I've done everything I can and I should just reformat the drive? (and if so, what should I use for file recovery after the drive has been reformatted?) Thank you for easing my tired, troubled mind, I hope!


Harry Kuhman
10-14-2009, 01:38 AM
I don't know the full answer for your problem, and unfortunately sometimes Windows just mucks up a partition so much that Knoppix can't mount it.

A few concepts that you should be aware of though: sda, sdb, sdc and so on are drives, with sda being the first SATA drive.
sda1, sda2, sda3, and sda4 are parimary partitions on the sta drive, and sta5 on up are logical drives on an extended partition if one exists. Of course, you mount partitions, not drives. I'm hard pressed to know why you would have sta3 and not sta1. Not saying that you can't, just doesn't seem right.

Occasionally Windows messes up it's own partition table, and can't find the partitions. In this case Knoppix can recover the partition table with either the gpart or testdisk commands. Type man gpart or man testdisk at a shell prompt for details. gpart takes a little more thinking to use, as there are more command line switches, but I consider it far better and safer than testdisk, which gives up a lot of control.