View Full Version : Unable to Run Knoppix 5.1.1 from USB Flash Drive

10-18-2009, 07:56 PM
Hello Everyone,

I'm following the instructions posted here.


I found that I was using a corrupted Knoppix ISO, and have been able to get the USB drive to run Knoppix through an emulator. My second goal was to make the USB drive bootable. The problem is that running it from Windows, or other, requires the ISO file to be on the drive, while booting from the drive creates its own "file" the same size as the original ISO. This normally wouldn't be a problem but I'm trying to fit it on a 1GB USB drive. Anyone know if both functions are possible without having two 700MB files on the drive?

Any help is really appreciated. Thanks ahead of time to anyone who has any input!

IBM Thinkpad T43
Microsoft Windows XP
1.73 GHz CPU
+1GB USB Flash Drive

01-01-2010, 08:47 PM
I had the same problem albeit with Knoppix 6.2.

I've installed Knoppix on my USB device via the normal Knoppix Menu
Then I've created the script below (found somewhere in a blog) and saved as Start_Knoppix.bat
The good news is: it works well under Windows XP
The bad news is: It doesn't work under Vista (and I have no clue why)
Another bad news is that I haven't figured out how something similar would work under Linux (using OpenSuse 11.2)
Maybe somebody with more skills have an idea?


@echo off



echo Select Drive Numbers:


wmic diskdrive get Caption,Index,InterfaceType


set /P dn=Index of boot device:


echo Boot Knoppix ...

qemu.exe -L . -boot c -usb -m 512 -kernel-kqemu -M pc -soundhw sb16,es1370 -localtime -hdb //./PhysicalDrive%dn%


Harry Kuhman
01-01-2010, 08:57 PM
.... (found somewhere in a blog) and saved as Start_Knoppix.bat
The good news is: it works well under Windows XP
The bad news is: It doesn't work under Vista (and I have no clue why)...
I'm very confused about what you are talking about. Knoppix is it's own operating system. Be it from CD, DVD or for those who can get it working, from a flash drive, Knoppis should be started from the computer's BIOS, booting into Knoppix just as you would boot into Windows on the hard drive or a Windows install disc. You do not run Knoppix "under" XP or other operating systems (except if running it in a virtual machine such as VMware player, which doesn't seem to be discussed here).

01-01-2010, 09:08 PM

seems my response was not complete. What I actually did was to download qemu-0.9.1-windows, and placed that folder on the USB stick. I also installed kqemu (although it works also without). Putting the batch file discussed previously in that folder and executing it under Windows XP starts Knoppix from the stick. No ISO image needed.
It doesn't work from Vista (tried with 2 different PCs and with/without Superuser rights, but no joy).

Do you have an idea on how to run Knoppix from the USB-Stick (no ISO!) using VMplayer in Vista?

Harry Kuhman
01-01-2010, 09:27 PM
That explains it. qemu is a processor emulator, effectively a poor man's virtual machine that you are running Knoppix in under XP. That it doesn't work under Vista doesn't surprise me, lots of stuff doesn't.

As to running in a VM, please refer to the very long thread (http://www.knoppix.net/forum/viewtopic.php?t=11796&start=0) by ruymbeke in the hdd install forum. Be sure to read add 596 entries ;-) . He does boot from the ISO though, using a file copy of it as a substitute for an actual CD or DVD in the vrtual machine. This makes perfect sense to me, since you need to boot from something, and a copy of the ISO seems to make much more sense than some "installed" knoppix that usually breakes when installed. If you don't want the Knoppix ISO, why not just install Debian in the virtual machine (or replace Vista with it) and run from a system intended yto be installed on hard disk?

01-01-2010, 09:45 PM
Thanx, I'll give it a try.
Just for the records: qemu does run under Vista, I tried it with DSL, but it seems to have its problems with Knoppix (non -ISO). That's really a pitty. It would have been so easy: put Knoppix on your USB, add qemu and here you are. Seems still to be a dream ....