View Full Version : NVidia driver installation

11-21-2009, 11:47 AM

I am new to Linux, thus please explain how to install the Nvidia Drivers in Knoppix 6.2. I made a hard disc installation and everything
works fine. But I am not able to install the "NVIDIA-Linux-x86-190.42-pkg1.run" driver.

Please check the log below and explain in easy words for a newbie what went wrong. It looks like some kernel problems...

Many thanks!

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Nov 21 12:31:00 2009
installer version: 1.0.7

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 190.42.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/'
-> Kernel output path: '/lib/modules/'
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

11-22-2009, 03:43 PM
Same problem and error message here. I first tried the easier Debian way of installing NVidia drivers right from the repos, both using the default repo (which brings in the Lenny/Squeeze 173.09) and the -t unstable switch to bring in Sid's 190.42. Just got dependency issues preventing the install. Aptitude wants to install the non-Knoppix customized Debian kernel's and so that dog won't hunt of course. I checked for the usual dependencies (build-essential, linux-headers, etc) and they, like in the previous versions of Knoppix DVD, are already installed. The nvidia-kernel-common package installs fine but as soon as nvidia-kernel-source installation is attempted I get the dependency on Debian kernel's issue. So module-assistant (which does install fine) will not be able to install or use it either. When trying the 173.09 I attempted to install the nvidia-kernel-686 but get the same dependency issues.

The readme's instructions regarding init 2, inti 5 do not work, only ctrl-alt-F1 brings up a console and running the init command from there leads to the same blinking cursor that running it from KDE's Konsole brings up. There's no KDM at /etc/init.d/kdm to stop for the downloaded driver either. That would get rid of the need to use init 2 to clear the hurdle of a display manager running for the downloaded driver but apparently Knoppix calls KDM something else.

The nv driver does work just fine for the normal 2D activities but getting the nvidia driver installed opens up worlds of stuff. And the other glitch of the console switch not working disables the ability to edit, get modules loaded, and restart X in the same bootup.

No idea if these are bugs or intentional, but at least the console restart X stuff looks like it was intended to work like always based upon it being mentioned in the cheatcode readme on the DVD.

12-25-2009, 02:16 AM

That got me started in getting the nvidia driver installed. I had to use the google translator to get it in English.

All I did from that post is to make the new kernel source though. The guy is right that the process is lengthy. It took my computer an hour and a half! I used the Debian way to install the drivers from sid afterwards and it worked fine. No need for the nvidia install blob. The Debian maintainer keeps the version in sid pretty up to date so I expect he'll have another update soon since nvidia just updated its official Linux release.

Once the kernel source is rebuilt:

I already changed /etc/apt/apt.conf.d/00knopppix to have the default release be testing since the vast majority of knoppix IS squeeze already. If you don't want to do that then add -t testing to the first line below.

sudo aptitude install nvidia-kernel-common module-assistant

sudo aptitude install -t unstable nvidia-kernel-source

That'll bring in a bunch of debian dev tools that I think even the downloaded nvidia installer might need to work properly (meaning the nvidia-kernel-source package). So if you want to install the downloaded nvidia driver I would first run aptitude install -t unstable nvidia-kernel-source and cancel out of it, then write down the packages it wanted to bring along and install them yourself.

m-a update
m-a prepare
m-a build nvidia
m-a install nvidia

That skips the m-a get step which m-a a-i includes. I don't want it to get the nvidia source since I already did that and have the version I want m-a to work on.

aptitude install -t unstable nvidia-glx nvidia-settings

Then when booting I do:

knoppix lang=us keyboard=us xkeyboard=us screen=1024x768 depth=24 xmodule=nvidia desktop=kde

Maybe you just need xmodule=nvidia but that's what I specify for my system.

No need to work on xorg.conf as those knoppix cheats get nvidia started properly.

I turned off the KDE4 desktop effects in its settings because although they work, they showed some odd defects compared to how they work on my real Debian Squeeze install. Like, the wobbly windows want to wobble but they're stopped by some other effect of a bracket around the windows when I move them. Plus, I turn that off for games, virualization and wine with alt+F12 even with my real install.

Weird that knoppix included the linux-headers but left out the parts of it that enabled the building of modules.

Here's just the commands for the DVD to rebuild them from that post:

sudo su -
cd /usr/src
mv linux-headers- linux-headers-
tar xjf linux-source-
ln -s linux-source- linux
cd linux
make oldconfig
make prepare

Then wait a long time. :)

And if you are using the cd then you can get that source from:

wget http://debian-knoppix.alioth.debian.org/packages/linux-source-

And install it with:

sudo dpkg -i linux-source-