View Full Version : Knoppix 6.2 DVD installs nicely to USB flash drive

12-31-2009, 12:02 PM
Hi again. Knoppix 6 has its own USB flash drive installer script (/usr/bin/flash-knoppix), so it's not necessary anymore, but I tried manually installing onto USB anyway.

I used my old USB flash drive installation guide, here:


It worked great for putting a Knoppix 6.2 DVD on an 8GB USB flash drive, and I'm typing this post from within it now.

Knoppix 6.2 is a great improvement over the original Knoppix 6.0 release. It makes Knoppix useable again. The DVD starts to have a decent amount of useful software on it again, although it still doesn't approach the treasure hoard that was Knoppix 5 (among other things, useful system diagnostic programs like "smartctl" are still missing).

There's just one thing to change, about the instructions:

Everywhere the /cdrom/ path is used, change it to /mnt-system/ path instead.

Same content, different directory name. Having it named "cdrom" is increasingly misleading these days, with DVD and USB becoming more common.

That's about it. Worked the first time, although the very large "KNOPPIX" file, exceeding the 2GB recommended maximum size limit of the FAT32 filesystem (and the UDF filesystem which the DVD uses!), got me worried for a while. It's just barely under the 4GB absolute maximum size limit of a file, so it was still OK. I'm surprised that Knoppix took a step backwards: Knoppix 5 was split up into two separate files, which neatly solved this problem, but they chose not to do it in Knoppix 6 for some reason.

Anybody else tried this? Or, with the flash-knoppix script now in wide use, it's been completely forgotten to the mists of time?


01-06-2010, 03:37 PM
I have installed to flash drive using flash-knoppix. I have found one thing that is a little inconvenient though. It may be the way I am working with it. I want to be able to save personal info (links, email, etc) as a normal user. It doesn't seem to allow such even though I have the space on the drive. Am I doing something wrong? Is there another method to installing to the thumb drive?