View Full Version : Cannot write to external disk drive

01-14-2010, 10:17 PM
My Gateway T-1616 laptop with Windows Vista crashed. It appears that Windows does not exist. I would like to recover my data.

I inserted the KNOPPIX 5.1 into the DVD drive and then connected a Maxtor One Touch external hard drive into the laptop's USB port. The external hard drive is recognized. Its icon Hard Disk [sdc1] is just below the icon for the laptop's internal hard drive Hard Drive [sda2]

I would like to copy files from sda2 to sdc1. However this message appears "You cannot drop any items in a...u do not have write permission." I have tried right clicking on the sdc1 icon and using "Mount", and "Change read/write mode".
But still was getting the message that sdc1 was not writable.

I tried again and something happened. Not sure what. Not sure where data was written. When I try to open sdc1 I get a long message " Could not mount device. The reported error was: fusermount: mountpoint is not empty fusermount: if you are sure this is safe, use the 'nonempty' mount option Failed to create FUSE mount point: No such file or directory Retry to create FUSE mount point FATAL: Module fuse not found. Unmounting /dev/sdc1 ()

01-18-2010, 01:43 AM
First: How is that external drive formatted? If it is a NTFS version, it might be risky to write to it from Linux.

Second: When you use Linux for such rescue/forensic operations, it is a bit dangerous to rely solely on end user interfaces designed for normal operation.
You could open a terminal window, type "su" to become super user (root), and first get the list of drives/volumes, by issuing the command "fdisk -l".
Then you could try to manually mount the external drive read/write, and then proceed from there. If you write to a NTFS volume, you should back up the existing data on it forst.