View Full Version : Help to automatically load the ethernet module b44 at boot time

06-26-2010, 11:29 PM

I'm booting "knoppix desktop=kde" on a Dell Dimension 2350, and the ethernet module doesn't load at boot time. I can connect afterwards by loading the module manually
# modprobe b44
# dhclient eth0

Is there a way to make this b44 module load automatically at boot time? (A boot parameter, I'm hoping?)


# lspci -v
01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
Subsystem: Dell Device 0127
Flags: bus master, fast devsel, latency 32, IRQ 17
Memory at ed000000 (32-bit, non-prefetchable) [size=8K]
[virtual] Expansion ROM at 18000000 [disabled] [size=16K]
Capabilities: [40] Power Managemetn version 2
Kernel modules: b44

06-27-2010, 08:53 AM
The easiest solution is to append the command in /etc/rc.local - it will load it, but it's not the right one

06-27-2010, 09:39 AM
There is a file /etc/modules. Maybe you can add a line with the name of your module so that it is loaded at boot time.

06-27-2010, 09:50 AM
I can see now that b44 driver is blacklisted by default. You can edit /etc/modprobe.d/broadcom-sta-common.conf and put # in front of b44.
This should do the trick, if not use the rc.local
And I just notice now the response from klaus2008. You can add b44 in /etc/modules, but still the first thing I would try is to unblacklist it