PDA

View Full Version : Changing from default env - LANG=de_DE@euro and LANGUAGE=de



RockMumbles
01-07-2003, 08:33 AM
Hello so far I'm really impressed with my knoppix hdd install. Way cool!

The only real gripe left with my system was the partial english/partial german problems with man pages and some console apps.

This fix will not fix KDE, OpenOffice, etc.

So I did some searching and found where the language variables are set, now I have my system running in english as I want it to.

The fix is easy as root edit (or if necessary make) the /etc/sysconfig/i18n file and use your country's info, here is my US-english file:

LANG="en_US"
COUNTRY="US"
LANG="en_US"
LANGUAGE="en"
CHARSET="iso8859-1"
XMODIFIERS=""

Thanks goes out to everyone here that is helping out with this great distro! I was thinking (dreaming) about Mandrake 9.0 because it is gcc 3.2 compiled, but I have something much better now, I have a "debian on the edge system" that ROCKS! Knoppix rules!

L8r,

rock

eadz
01-07-2003, 09:37 AM
the offical debian kde 3.1 debs are compiled with gcc 3.2 :) and the should be in sid end of this week/early next week.. :)

aay
01-07-2003, 06:18 PM
RockMumbles,

Good work. I have sent this info to Christian Perle who is the maintainer of the knx-hdinstall script. Perhaps it will enable him to provide more language options in his install scipt.

Darkehorse
01-07-2003, 10:48 PM
Even aftering editing the aforementioned file, I still get German when logging in with the Knoppix user (Logging in as root gave me a wizard where I was able to choose my desired locale/language). Hint to future followers of the thread, don't bother trying to edit that file without being logged in as root or other equivalent superuser.

-Darke

PS Knoppix does rule! The best thing about it is the autodection of hardware. A few years ago I remember trying to configure Redhat on my network at work. I gave up after about a week. Knoppix had me up in running in a little over an hour!

RockMumbles
01-08-2003, 04:32 AM
Check out this help file Install part (7)+ for setting up KDE for english:
http://www.freenet.org.nz/misc/knoppix-install.html
I also select the US (or your language) keyboard from the keyboard config applet next to the clock and then close it out.

In X (kde, fluxbox, icewm. xfce, etc.) things were working in english OK, but from a console things were part german, part english.

Also see Andrew Foster's post about home directories:
http://www.knoppix.net/forum/viewtopic.php?t=297

I made a shell script from his code, I call it fix-home following is the code:
(Note: this code is all one line)

#!/bin/sh
for i in `grep -rlis \/home\/knoppix ~`; do perl -p -i -e "s/\/home\/knoppix/\/home\/$1/g" "$i"; done

you could cut the code from this page and paste it into an editor that does not word wrap, make sure the " for ... ... done " is all one line, and then as as root move it to /usr/local/bin, then made it executable by:
chmod 755 /usr/local/fix-home

You can run it as root by typing:
fix-home user-name
where user-name is the user-name for the user directory you want to fix. Or you can run it in a console logged in as the user.

HTH,

rock

anushatech
03-15-2003, 07:17 AM
I have a similar problem.

My keyboard is configured as a German Layout when I boot to shell. Under Kde I have no problems.

I don't have the " /etc/sysconfig/i18n " file the directory is empty.

Should I just create the file with the text listed in it ?

RockMumbles
03-21-2003, 07:11 PM
anushatech

I just now saw your post, I would make the i18n file from my first post. That would put your console keyboard in US-english.

HTH

rock

raid517
03-26-2003, 02:39 AM
What are the correct settings for this file for UK English?

Q

RockMumbles
03-26-2003, 02:51 AM
What I would do is look in /usr/share /i18n/locales and compare the us entry en_US to the en_GB file, for starters it looks like:

LANG="en_GB"
COUNTRY="GB"
LANGUAGE="en"

edit
The /etc/sysconfig/i18n language entries will only fix console language problems. KDE, openoffice, etc. will have to be fixed separately.
/edit
HTH

rock

raid517
03-26-2003, 03:40 AM
No I did that and it didn't work anyway... Surely there must be a way of making English your system wide setting? I'd love a debian based distro that is easy to install, but this language thing where half the applications I open are in german and my whole root directory/applications are in german too is really starting to get me down...

I do wish there was much better english suport from this distro...

Q

RockMumbles
03-26-2003, 06:08 AM
If you want an easy to install debian based system check out Libranet.

It seems that the 3.2 knoppix releases have the most language problems, I think my best hd install was maybe the 01-01 version, or maybe even prior to that.

rock

diptoe
09-16-2003, 11:54 AM
I've tried the fix to /etc/sysconfig/i18n to change to uk english (with en_GB) but I also seem to get the same format. The terminal windows are fine but I'm a startx fan so I like to have things working before that. I have noticed that my key remaps to # - does anyone know if this means I AM in english but knoppix thinks I want US keymapping?

fingers99
09-17-2003, 01:43 PM
To change the keyboard you just change

/etc/init.d/keymap.sh

as root, edit the line:

loadkeys /usr/share/keymaps/i386/qwerty/us.kmap.gz (or whatever)

(to the keymap you want -- uk.keymap.gz -- for example)

and run

/etc/init.d/keymap.sh reload

diptoe
09-17-2003, 05:47 PM
thanks fingers99, you're a star! :D that was the final think I needed to get it working. I did have to do the changing "de_DE" to "en_GB" as well but I was really stuck on that keyboard mapping thing - I was just fixated on it being a language issue.