View Full Version : Problem with the installation on SD card

09-20-2012, 08:43 AM

We installed Knoppix 7.0 on a 4GB SD card. The computer has the option of booting from the SD card. After booting from the card, I get the following error:

Could not mount disk to /mnt-system. Starting debugging shell ...
sh: can`t access tty job control turned off
/ #

What could be the problem?



09-26-2012, 12:55 AM
Are you able to boot successfully from the card using a card reader?

09-26-2012, 07:10 AM
Yes, from the other SD card reader connected via the USB port Knoppix boot successfully.

09-26-2012, 07:41 PM
It's difficult to pinpoint the problem. Obviously there is some kind of conflict with the BIOS/card, and the Linux kernel is able to get past it, in the initial boot process.
Does read/write with the internal reader work flawlessly when mounted in a running system? Will it, eventually, work better mounted readonly (cheatcode noimage)?
Will it work with the fromhd option, booting the kernel from the card and reading KNOPPIX from, say, a USB stick?

09-29-2012, 12:29 AM
Maybe the the built-in card reader needs kernel modules that are not compiled into the Linux kernel but are present in the subdirectories of /lib/modules/. Issuing the command 'lsmod' after booting Knoppix off the CD could be helpful.

10-08-2012, 08:52 PM
If I run Knoppix from the CD and next I put the SD card into the internal SD card reader, everything works fine. I can read the contents of the card. The command lsmod shows that the module is used rts5139. Hardware card reader is Realtek 5129. The problem is with booting from the SD card. RTS5139 module is compiled into the kernel.

10-09-2012, 08:44 AM
As I wrote, we could know that the kernel was able to read, because it did in fact boot. So necessary modules must have been in place - though maybe not the exact correct ones. When it can't get past initial system mounting this way, but everything works fine booting from somewhere else, it may be the fluxbox routines responsible for the first init that don't work quite as they should.

Will it work when you boot from CD and use the KNOPPIX image in the card reader (fromhd=<reader device designation>)? If it does, this is really strange..

10-10-2012, 07:39 AM
When I will boot from CD and use the image KNOPPIX in the card reader, it does not work.

10-12-2012, 09:39 AM
I was about to try Knoppix on SD when I came upon this thread.
I have exactly the same problem on another PC, the Acer Revo RL70 which has the realtek pcie card reader (and you can choose to boot from it).
Trying to boot Openelec or Ubuntu from SD card.

The system boots up using the SD card but then it cannot read/see the partition on the card that it booted from.
The OS will be launched if the SD card is used via a card USB reader.
IF the partition(s) are present on USB (copied from SD) you can boot from SD slot and launch the OS from there.

I believe we are seeing the same thing - kernel loads from SD and executes, but is not capability to read/see The SD in PCIe card reader, only the HDDs, USBs.
Im new to linux - but that makes sense.

I will try out Knoppix SD when I return home, but I fully expect to get the same result.

I do hope an easy solution can be found, although its nothing urgent - it does niggle.
Thanks for reading.

My problem detail in this thread

10-12-2012, 05:26 PM
update : I installed/made a live SD card using the 7.0.4 dvd.
It boots and is currently showing the knoppix desktop - progress