View Full Version : Floppy Boot Problems and Other - Help Appreciated

06-22-2003, 03:28 AM

I don't think this has been addressed before, I have looked over much of this board but haven't found what I am looking for.

I have really had a LOT of good luck with this linux installation, it identified my hardware better than windows did. It works amazing and I soon decided I would put it on my hard drive.

I had tried once before with slackware and their slackzip that could be put on a FAT32 drive, it worked well for a few weeks, and I got all my hardware working eventually unfortunately windows crashed and I had to reformat. This is my next attempt.

I just got a brand spanking new 80gb WD 7200rpm drive and decided I would move windows off my little 4 gig I was replacing. That freed up an entire drive for Knoppix. I got windows running on my now first drive, and ran the knx-hdinstall script to install on the 4 gig, it worked very well and some of my earlier experience helped. I got I finished the install easily and rebooted.

I was now presented with the lilo menu, containing both windows and linux. I was very pleased. I tried to boot windows but NOTHING happened, it just said "booting Windows(hda1)" and did not continue, however, linux boots fine.

I went into linux and searched this board and found this very useful article http://www.knoppix.net/forum/viewtopic.php?t=2604&highlight=lilo+windows. It explained that I should use GRUB, and what not, fine, I followed the instructions but soon realized I was supposed to put LILO on the linux partition. I reinstalled and did so, I made a boot disk but when I tried to boot with the disk I got this error, "Boot Failed" right at the begining before anything happened.

I tried several different things but they all failed. I took a different angle, I booted on the Knoppix cd (a very useful tool) and took a look at installing LILO into the MBR as well as the partition. I didn't know how this would work, I assumed it would work fine but I didn't get that far, I found this article http://www.knoppix.net/forum/viewtopic.php?t=2564&highlight=lilo+reinstall
that explained how to install lilo. Unfortunately when I try to chroot to /mnt/hdb1/ (which is mounted) I get a long error, it repeats

bash: /dev/null: Permission Denied

more times than will fit on a screen. At this point I went for help. I may be able to figue more out but its quite late and I'd like to see what people have to say, have I done anything wrong, what is causing these problems. How do I fix or circumvent them. Any help or suggestions you can give would be greatly appreciated. Oh, I'm pretty newbieish so a good explanation would be useful. Thanks so much for any help.

My system info is:

hda = Western Digital 80gb 7200rpm
hdb = Quantum Fireball 4gb
256 mb ram
Asus motherboard

if you need anthing else, just ask.

06-22-2003, 07:54 PM
Go to /etc/fstab , open with kwrite. It shows where the devices are
located. It's a little deceiving - my shows windows hdg1, but in LILO
I need to put hdg ! Always default to 3-letter for booting windows.
My config = 40GB Maxtor 19.5 | .25 | 19.5 .

# /etc/fstab: filesystem table.
# filesystem mountpoint type options dump pass
/dev/hdg6 / ext3 defaults,errors=remount-ro 0 1
/dev/hdg5 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
# partitions found by Knoppix
/dev/hdg1 /mnt/hdg1 vfat noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0
#/dev/hdg6 /mnt/hdg6 ext3 noauto,users,exec 0 0
/dev/scd0 /cdrom auto ro,noauto,user,exec 0 0
/dev/scd1 /cdrom auto ro,noauto,user,exec 0 0

Its always best to use LILO, from my experience.

Also after installing Knoppix, it said hda1 for DOS. I inserted hdg and Windows - you only need the first 2 lines.

If your windows dev is # , deleted it and you can add an
HDD-WINDOWS to your Knoppix desktop.

Also I would suggest using ext3-journal FS for Knoppix, I've read some bad thinks about Resierfs. You dont have to use xfs filesytem,
even though the Knoppix use's an XFS kernel.

Headers-Source: http://developer.linuxtag.net/knoppix/i386/

Good Luck !

06-22-2003, 08:16 PM
Also I would suggest using ext3-journal FS for Knoppix, I've read some bad thinks about Resierfs. You dont have to use xfs filesytem,
even though the Knoppix use's an XFS kernel.

Good Luck !

I've read the same things but I have been using reiser for some time now and have never had any problems of course as with anything YMMV.

06-23-2003, 01:19 PM
Just a little update, I was wrong with 3-Letter for HDD. I used hdg1 instead of hdg.