View Full Version : SOS - stuck in a desert and I broke KNOPPIX :(

06-09-2014, 04:51 PM

Am in a desert (Saudi Arbaia) for 3 months and using my work laptop and my trusty knoppix pendrive.

This morning I switched it on to download GoT, and like a royal plonker forgot to plug the laptop in, so coming back from work I realised I had most likely trashed my pendrive.

NOW, when I try to boot I get this:

mount: mounting unionfs on /UNIONFS failed: No Space left on device
/init: exec: line 1022: /sbin/init: not found

I KNOW the 'no space left on device' is NOT to do with downloading GoT, as I had on a previous occasion accidentally knocked the pendrive out, and had the same error occur. That time, after throwing my rattles out the pram I begrudgingly made a new pen drive, this time in a desert I DONT have that option.

I have looked at another post somewhere, where the advice was as follows:
a) Boot KNOPPIX CD, first run dosfsck or fsck.vfat and so on on the VFAT partition to check for possible VFAT corruption
b) Boot from KNOPPIX CD, manually cloop-mount the flash KNOPPIX compressed image, to see if that is possible to see the problem this way.
c) Boot from KNOPPIX CD, e2fsck on knoppix-data.img to check for corruption and possible loop mount it manually and check for corruption.

Being a mere mortal, I dont understand this or know how to do this and the post I read didnt provide any direction on how to do this.

Is there anyone out there who can help me please? Can I recover my pendrive? I'm not stupid but I do need a numpty's guide!!

Much obliged if you read this far!


(p.s. think its version 7.05 I am using)

06-09-2014, 07:17 PM
Greetings, pastabake.

It may be that you have damaged your persistence file, but that the rest of your
Knoppix LiveUSB configuration is still intact. If you have made a lot of changes
to your LiveUSB then this may not be good news, but at least it will let you know
more specifically what your problem really is.

Try booting with a 'knoppix noimage' cheatcode to see if your LiveUSB boots OK,
but that all your changes are missing. If it doesn't boot with the noimage
cheatcode, you may need to start all over with a fresh LiveUSB and a new
'empty' persistence file.

If your LiveUSB boots ok with the noimage cheatcode,
but all your changes are missing then your options become:
1. repair the damaged persistence file; or
2. start over with a fresh, empty persistence file, and
a. reconstruct your lost changes from backup material; or
b. reconstruct your lost changes from procedural notes; or
c. reconstruct your lost changes as best you can, somehow.

In my time, I've had this problem and used 2 a, b and c as work-arounds;
I don't know how to simply repair a corrupted persistence file.

07-11-2014, 12:45 PM
Thanks for your response!

Unfortunately I have basic noob understanding and had no idea how to execute these work arounds.

In the end I gave up and made a new live usb install (version 7.2).

I now have two issues that will make you think I am truely on another planet type ret4rd!

1) For the life of me I cant find how to make a new post on knoppix forums, days of looking and I cant find the effing post button. wtf!?

2) I cant work out how to make the drive persistent. All previous versions would give me the option on boot up to make knoppix pen persistent. This version 7.2 does no such thing and I have not been able to find anywhere on the net that gives a simple how to on this, for 7.2. Any chance you could be so kind as to help a muppet out?

I looked at this on gparted thinking maybe I needed to make a new partition but the whold disk seems to be used, surely the amount of used space should have been around 700mb.

Any help would be greatly appreciated. Thanks :)

p.s. I know this is strictly the wrong place to post but, see issue 1)!

Werner P. Schulz
07-12-2014, 11:10 AM
I cant find how to make a new post on knoppix forumsSelect one of the Knoppix.net Forums; after this you'll see in the upper left corner the button "+ Post New Thread"

I cant work out how to make the drive persistent.Have a look at Harddrive Installation (http://knoppix.net/wiki/Category:Hard_drive_Installation). For the flash disk install of Knoppix DVD you need at least a 8GB USB stick.
And also test the install DVD with the Cheatcode "knoppix testcd" first.

07-12-2014, 12:42 PM

last night I realised I could make a new knopix pendrive with my existing pendrive with optional overlay, this allowed me to make a new persistant pendrive. The first one I tried on a partitioned disk so that the 2nd partition would be a data partition I could access on any other os machine but its buggy as hell and I cant mount/access the the partition and generally the whole system just doesnt play ball. The second I just used the whole 4gb pendrive for the knoppix install and it is successfuly persistent.

I had previously tried the additional overlay partition but could not understand the difference. Reading your link has enightened me further, altho is reinerFS format something I can access data on with other os'? does this get created for me or do I neet to use gparted to set up the pendrive fisrt?

I have a 32gb pendrive I might try with the dvd version, although at the moment I am also tempted to try out crunchbang on it. testing them out, I have not mananaged to set up a data partition on either yet. Also going to cruncbang makes me feel like I am cheating on my knoppix gf lol.

07-12-2014, 04:07 PM
I tried on a partitioned disk so that the 2nd partition would be a data partition I could access on any other os machine but its buggy as hell and I cant mount/access the the partition and generally the whole system just doesnt play ball.

Greetings, pastabake.

With the reiserfs partition approach, after your created a partition,
did you also then format that partition as reiserfs?
If not, that may have been a part of your earlier difficulties.

It looks like you and Werner have cleared up most of your problems.
Glad things are coming along for you.