PDA

View Full Version : Configuring a mouse



standmatt
06-23-2003, 02:09 AM
I cannnot get a mouse working on knoppix once i hdd-install. Ive tried my usb mouse which i use with windows, and i used with knoppix on cd. I've also tried mutiple Ps/2 mice (All microsoft, 2 with wheels and 1 without) with no luck. I'm completely new to this, it's my first linux install, so it would be wonderful if someone could point me to a link with easy-to-follow instructions for either my usb or Ps/2 mouse. Also, i could buy a serial mouse if this would be easier to install. If you need more information I would be happy to provide it, so just tell me.

Thanks
Matt

fingers99
06-23-2003, 02:53 AM
Generally PS2 mice are easier to set up.

Just go here -- the same tool which sets up your monitor can set up your mouse :wink:

http://www.knoppix.net/forum/viewtopic.php?t=3191

standmatt
06-23-2003, 03:52 AM
Ok, i used xf86cfg, and when i'm in it the mouse works! The problem is when i try to hit exit, i hit ok twice in the diolouge bowes about where to make the changes, then the screen flickers and it goes to a sort of grey color and seems to hang. I can switch to the gui by hitting ctrl-alt-F7 but then when I switch back to the command with ctrl-alt-F2 it's still the same grey color. Then when I reboot (from the gui, ctrl-alt-del,restart) the mouse doesn't work so I go back into xf86cfg and the changes that I made not taken effect.

Thanks
Matt

standmatt
06-23-2003, 04:20 AM
Update:

When I went to try the steps in the above post further i though I noticed a continuous flicker on the left hand side of the screen. Then i looked more closely and i saw that it was text. So, i played with my monitor settings until the text was readable.

It went on and on about the changing of the files, then it displayed version info, then it showed-

Error: Sigill Caught
SetClientVersion- 0.7
SetMouseSettings- (all of the settings)
SetMouseSettings- device: /dev/mouse
SetMouseSettings- Suceeded
root@linux:-# x connection to: 0.0 broken (explicit kill or server shutdown)


(There may be some errors in the above text, as it was extremely hard to read ( I had to copy it to paper and then type it back in to another computer)
What do I do???


Thanks Everyone,
Matt

garyng
06-23-2003, 04:56 AM
IMO, first thing first, don't even touch that xf86Cfg program. It is so buggy to me.

For your mouse, just post your /etc/XF86Config-4 file.

newiaqua
06-23-2003, 02:11 PM
Knoppix sometimes turn off mouse support:)
you could also try: gpm -t ps2
And the configuration(speed...etc.) is under peripherals in Control Center(KDE).
some bios-es are not patched against this mouse problem->you could update your bios.
scrolling is possible also just read the XFree HOWTO and add some lines to your Input Device in XF86Config-4.

standmatt
06-23-2003, 04:11 PM
just post your /etc/XF86Config-4 file

I cant find this file, how to I access it?

Ok, now for the first time knoppix seems to be recognizing my usb mouse (Microsoft Optical 5 Button ItelliMouse Explorer). I comes up with something like new USB device, then it tells me the make and model of the mouse, then it says that no driver is claiming the device. I can tell that the mouse is on because it's glowing red, how do I configure this mouse???\

RockMumbles
06-23-2003, 05:48 PM
your config file is:
/etc/X11/XF86Config-4

--rock

standmatt
06-23-2003, 09:42 PM
Here are the contents of the XF86Config-4 File (I accesed it by using the knoppix cd if that makes a difference)

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
InputDevice "Serial Mouse" "CorePointer"
# USB Mouse not detected
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/ttf/western"
FontPath "/usr/share/fonts/ttf/decoratives"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/CID"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "Module"
Load "ddc" # ddc probing of monitor
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "bitmap" # bitmap-fonts
Load "speedo"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

EndSection

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

# Auto-generated by KNOPPIX mkxf86config

Section "Monitor"
Identifier "Monitor0"Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
InputDevice "Serial Mouse" "CorePointer"
# USB Mouse not detected
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/ttf/western"
FontPath "/usr/share/fonts/ttf/decoratives"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/CID"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "Module"
Load "ddc" # ddc probing of monitor
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "bitmap" # bitmap-fonts
Load "speedo"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

EndSection

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

# Auto-generated by KNOPPIX mkxf86config

Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "true"
VendorName "DEL"
ModelName "DEL3142"
HorizSync 30 - 85 # DDC-probed
VertRefresh 50 - 160 # DDC-probed
# These are the DDC-probed settings reported by your monitor.
# 1024x768, 85.0Hz; hfreq=68.68, vfreq=85.00
ModeLine "1024x768" 94.50 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
# 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 800x600, 85.0Hz; hfreq=53.67, vfreq=85.06
ModeLine "800x600" 56.25 800 832 896 1048 600 601 604 631 +hsync +vsync
# 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
ModeLine "800x600" 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600, 72.0Hz; hfreq=48.08, vfreq=72.19
ModeLine "800x600" 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync
# 800x600, 60.0Hz; hfreq=37.88, vfreq=60.32
ModeLine "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
# 640x480, 85.0Hz; hfreq=43.27, vfreq=85.01
ModeLine "640x480" 36.00 640 696 752 832 480 481 484 509 -hsync -vsync
# 640x480, 75.0Hz; hfreq=37.50, vfreq=75.00
ModeLine "640x480" 31.50 640 656 720 840 480 481 484 500 -hsync -vsync
# 640x480, 60.0Hz; hfreq=31.47, vfreq=59.94
ModeLine "640x480" 25.17 640 648 744 784 480 482 484 509 -hsync -vsync
EndSection

Section "Device"
### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
Option "sw_cursor"
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
Driver "radeon"
VendorName "All"
BoardName "All"
# BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 16
SubSection "Display"
Depth 1Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
InputDevice "Serial Mouse" "CorePointer"
# USB Mouse not detected
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/ttf/western"
FontPath "/usr/share/fonts/ttf/decoratives"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/CID"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "Module"
Load "ddc" # ddc probing of monitor
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "bitmap" # bitmap-fonts
Load "speedo"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

EndSection

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

# Auto-generated by KNOPPIX mkxf86config

Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "true"
VendorName "DEL"
ModelName "DEL3142"
HorizSync 30 - 85 # DDC-probed
VertRefresh 50 - 160 # DDC-probed
# These are the DDC-probed settings reported by your monitor.
# 1024x768, 85.0Hz; hfreq=68.68, vfreq=85.00
ModeLine "1024x768" 94.50 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
# 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 800x600, 85.0Hz; hfreq=53.67, vfreq=85.06
ModeLine "800x600" 56.25 800 832 896 1048 600 601 604 631 +hsync +vsync
# 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
ModeLine "800x600" 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600, 72.0Hz; hfreq=48.08, vfreq=72.19
ModeLine "800x600" 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync
# 800x600, 60.0Hz; hfreq=37.88, vfreq=60.32
ModeLine "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
# 640x480, 85.0Hz; hfreq=43.27, vfreq=85.01
ModeLine "640x480" 36.00 640 696 752 832 480 481 484 509 -hsync -vsync
# 640x480, 75.0Hz; hfreq=37.50, vfreq=75.00
ModeLine "640x480" 31.50 640 656 720 840 480 481 484 500 -hsync -vsync
# 640x480, 60.0Hz; hfreq=31.47, vfreq=59.94
ModeLine "640x480" 25.17 640 648 744 784 480 482 484 509 -hsync -vsync
EndSection

Section "Device"
### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
Option "sw_cursor"
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
Driver "radeon"
VendorName "All"
BoardName "All"
# BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Option "DPMS" "true"
VendorName "DEL"
ModelName "DEL3142"
HorizSync 30 - 85 # DDC-probed
VertRefresh 50 - 160 # DDC-probed
# These are the DDC-probed settings reported by your monitor.
# 1024x768, 85.0Hz; hfreq=68.68, vfreq=85.00
ModeLine "1024x768" 94.50 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
# 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
ModeLine "1024x768" 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
# 800x600, 85.0Hz; hfreq=53.67, vfreq=85.06
ModeLine "800x600" 56.25 800 832 896 1048 600 601 604 631 +hsync +vsync
# 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
ModeLine "800x600" 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync
# 800x600, 72.0Hz; hfreq=48.08, vfreq=72.19
ModeLine "800x600" 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync
# 800x600, 60.0Hz; hfreq=37.88, vfreq=60.32
ModeLine "800x600" 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync
# 640x480, 85.0Hz; hfreq=43.27, vfreq=85.01
ModeLine "640x480" 36.00 640 696 752 832 480 481 484 509 -hsync -vsync
# 640x480, 75.0Hz; hfreq=37.50, vfreq=75.00
ModeLine "640x480" 31.50 640 656 720 840 480 481 484 500 -hsync -vsync
# 640x480, 60.0Hz; hfreq=31.47, vfreq=59.94
ModeLine "640x480" 25.17 640 648 744 784 480 482 484 509 -hsync -vsync
EndSection

Section "Device"
### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
Option "sw_cursor"
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
Driver "radeon"
VendorName "All"
BoardName "All"
# BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Any suggestions
Thanks

Stephen
06-24-2003, 12:34 AM
Any suggestions


Here's one get rid of that config file boot from the CD get a working X config mount the drive and copy the XF86Config-4 to the HD. eg.


sudo mount /dev/hd?? /mnt/hd??
sudo cp /etc/X11/XF86Config-4 /mnt/hd??/etc/X11/XF86Config-4


And re-boot.

BTW is that the actual file because it does not look like any X config that I have ever seen or did you double post sections.

My XF86Config-4:


Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "PS/2 Mouse" "CorePointer"
# Serial Mouse not detected
# USB Mouse not detected
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
## FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
## FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
## FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
## FontPath "/usr/X11R6/lib/X11/fonts/Type1"
## FontPath "/usr/share/fonts/ttf/western"
## FontPath "/usr/share/fonts/ttf/decoratives"
## FontPath "/usr/share/fonts/truetype/openoffice"
## FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
## FontPath "/usr/X11R6/lib/X11/fonts/defoma/CID"
## FontPath "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "Module"
Load "ddc" # ddc probing of monitor
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "bitmap" # bitmap-fonts
Load "speedo"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

EndSection

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

# Auto-generated by KNOPPIX mkxf86config

Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "true"
# HorizSync 28.0 - 78.0 # Warning: This may fry very old Monitors
HorizSync 30-54# Warning: This may fry old Monitors
VertRefresh 50-120
# These are some Modelines that happen to work on many systems
# Especially the "1024x768" has been thoroughly tested, even on Laptops
Modeline "640x480" 25.175 640 664 760 800 480 491 493 525 #60Hz
Modeline "800x600" 40.12 800 848 968 1056 600 601 605 628 #60Hz
Modeline "1024x768" 85 1024 1056 1152 1360 768 784 787 823
Modeline "1152x864" 92 1152 1208 1368 1474 864 865 875 895
Modeline "1152x864" 110 1152 1240 1324 1552 864 864 876 908
Modeline "1152x864" 135 1152 1464 1592 1776 864 864 876 908
Modeline "1152x864" 137.65 1152 1184 1312 1536 864 866 885 902 -HSync -VSync
Modeline "1280x1024" 80 1280 1296 1512 1568 1024 1025 1037 1165 Interlace
Modeline "1280x1024" 110 1280 1328 1512 1712 1024 1025 1028 1054
Modeline "1280x1024" 126.5 1280 1312 1472 1696 1024 1032 1040 1068 -HSync -VSync
Modeline "1280x1024" 135 1280 1312 1456 1712 1024 1027 1030 1064
Modeline "1280x1024" 135 1280 1312 1416 1664 1024 1027 1030 1064
Modeline "1280x1024" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +HSync +VSync
Modeline "1280x1024" 181.75 1280 1312 1440 1696 1024 1031 1046 1072 -HSync -VSync
Modeline "1600x1200" 162 1600 1664 1856 2160 1200 1201 1204 1250 +HSync +VSync
Modeline "1600x1200" 189 1600 1664 1856 2160 1200 1201 1204 1250 -HSync -VSync
Modeline "1600x1200" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +HSync +VSync
Modeline "1600x1200" 220 1600 1616 1808 2080 1200 1204 1207 1244 +HSync +VSync
ModeLine "1800x1440" 230 1800 1896 2088 2392 1440 1441 1444 1490 +HSync +VSync
ModeLine "1800x1440" 250 1800 1896 2088 2392 1440 1441 1444 1490 +HSync +VSync
vendorname "Acer Peripherals"
modelname "54e"
ModeLine "1024x768/60Hz" 65 1024 1032 1176 1344 768 771 777 806 -HSync -VSync
ModeLine "800x600/72Hz" 50 800 856 976 1040 600 637 643 666 +HSync +VSync
EndSection

Section "Device"
### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
Option "sw_cursor"
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
Driver "ati"
VendorName "ATI"
BoardName "ATI 3D Rage Pro"
# BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 24
SubSection "Display"
Depth 1
Modes "1024x768/60Hz" "640x480"
Virtual 0 0
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768/60Hz" "640x480"
Virtual 0 0
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768/60Hz" "640x480"
Virtual 0 0
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768/60Hz" "640x480"
Virtual 0 0
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768/60Hz" "640x480"
Virtual 0 0
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768/60Hz" "640x480"
Virtual 0 0
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768/60Hz" "640x480"
Virtual 0 0
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "InputDevice"

Identifier "Mouse"

Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Driver "mouse"
EndSection


On top of every thing else wrong with the file it is missing a mouse section at the bottom.

standmatt
06-25-2003, 12:18 AM
Ok it's working now, thanks guys

Stephen
06-25-2003, 03:21 AM
Good to hear you got it going, could you post the steps you took so people searching the forum will find the solution to the problem not just the question itself.

standmatt
06-25-2003, 03:57 AM
Since the mouse worked with the knoppix cd I just copied the working XF86Config-4 file from the CD to the hard drive where the faulty XF86Confg-4 file was as per stephen's instrucions in the above post. Since I was already mounted to the hdd i just typed in


sudo cp /etc/X11/XF86Config-4 /mnt/hd??/etc/X11/XF86Config-4

Filling in the ?? with the id of my hdd, "c5" in my case

Hope this helps
Matt

Stephen
06-25-2003, 04:13 AM
Thanks for posting back what was it that you tried that gave you the config file you posted just wondering how it ended up like it that?

standmatt
06-28-2003, 10:37 PM
I'm not quite sure what i twas, maybe because I ran the XF86 Config program so many times