View Full Version : Internet problem with wireless card

06-25-2003, 09:05 PM
Hi. I'm new to linux. I have a Windows Wireless Network card MN-520. When I boot Knoppix I can see the name of the card among all the rest of my hardware. When Knoppix finally loads up and I try to get to a website it says, "An error occured while loading http://www.google.com
unknown host www.google.com"
I have an always on connection when im using windows.
I've tried to ping other websites but it doesnt work. It just says, "ping: unknown host www.google.com"
I did the "netcardconfig" and chose not to use DHCP broadcast (only because nothing happened when I originally chose yes). Then all I did was keep hitting ok when all the IP addresses started coming up (I didnt know what I was supposed to be doing).
I was reading other posts that said to use "ifconfig eth0". I did and then had no idea what to do next, along with "lsmod" and "lspci -v".

Please help if possible. I hope I provided enough information to solve the problem. If you have an answer or need more iformation from me feel free to either post here, Instant Message me at "FeelConscious" on AIM, or send me an E-Mail at "Koikioio@netzero.com"

06-25-2003, 09:20 PM
Did you try going to Knoppix-Network/Internet-Wavelan Connection? This is where it gives information about wireless cards.

06-25-2003, 09:29 PM
Yeah, but it says, "No wireless network card found."

06-26-2003, 05:50 AM
Yeah, but it says, "No wireless network card found."

Im also new to it... but i could be the Wireless Encryption. which is what im facing too.. the problem is .. where do i enter them.

06-26-2003, 02:58 PM
Regarding your card not being found:

Remove the card
Wait a few seconds
Put the card back in
Run wlcardconfig
Hopefully your card will be detected this time and you can fill in the relevant info and have it up and going.

06-26-2003, 03:01 PM
Of course the first thing you have to do before fooling with a wireless card is to make sure it's supported in Linux.

This page (http://www.linux-wlan.org/docs/wlan_adapters_supported_html2.html) is a FANTASTIC resource for determining what cards are supported and what cards aren't. It appears that yours is supported.

06-26-2003, 06:59 PM
I just wanted to say thanks for all the support! With that said I am still having difficulties.

I tried taking the card out, waiting a few second, then plugging it back in but it still says that there is no wireless card found.

I checked the compatibility of the card with linux on that website. It appears to be compatible. I noticed that when I boot up Knoppix it says that it is starting up pcmcia devices and then it says this, "card mgr[57] unsupported card in socket0"

I have a built in ethernet port in my computer along with the wireless pcmcia card. It isnt plugged in. Would this make any difference?

06-28-2003, 07:10 AM
I had a heck of a time getting my Orinoco silver card to work, though my problems were compounded 'cause I used a proxy server.

I remember reading somewhere that Knoppix had a problem with more than one Ethernet interface running at once (don't know if this is true) and if this is true one might have to disable the internal Ethernet connection first.

I would suggest that you consider a couple of things:

1) get your connection working with the internal Ethernet port FIRST,
2) change nothing in your configuration after you get this working but disable the internal Ethernet, and then
3) load up your wireless card and see if you can get it to work.

There are a few references out on the Web to getting wireless LAN cards to work with Linux/Debian/Knoppix. Search for either Knoppix (preferred) or Debian on Altavista/Google. I know that I found one or two sites with detailed info.

I found that I had to start PCMCIA services, networking and internet services to get my card to connect. I believe the default configuration in wireless for Knoppix is promiscuous - connect to any available.

Just make sure that your hub doesn't have encryption turned on initially - you don't need the complications while trying to get the basic connection to work. Check the logs on your wireless hub to see whether it is seeing the wireless cards attempts to connect as well - there may be some useful information there. Also, try more than one brand of wireless card - bring your laptop to a store that offers wireless cards for sale (and has demos). Ask to try them on the pretext that you are looking for a compatible one for your version of Linux to try - who knows, you might be??!

best of luck,

07-08-2003, 07:53 AM
I'm having a similar problem... The Wlan--supported list says my SMC 2532W-B card is supported, but on bootup I get an unsupported card [57] error... what a bummer because this seems like a cool distro... does anyone know what version of Linux-Wlan-Ng is on the most recent version of Knoppix?