View Full Version : On exit : dirty bit is always set

10-07-2018, 06:44 AM
Earlier versions of KNOPPIX always automatically unmounted any mounted devices on "halt" (init 0) or "reboot" (init 6) if the user had forgotten to do so.
Recently (since at least 7.4.2, maybe a lot earlier) this kind feature was removed; and then, in any future session, attempting to mount an external device, one might get the error message "device not properly unmounted". No problem, easily managed.
But on 8.2.0 I find that the boot device is itself left "dirty". Bu this I mean:
I operate KNOPPIX from a USB boot flash drive /dev/sda1. Every time I start up, if I try
$ dosfsck -r /dev/sda1
then I get
0x41 : Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
So, on exiting KNOPPIX, not even the boot device (let alone any others mounted during a session) is unmounted. This, surely, is an oversight.
Can anything be done manually just before exit? I tried the obvious "umount /dev/sda1" and "umount /mnt-system" but got the same error message "device is in use".
Any ideas? Thank you for your help!

10-10-2018, 06:25 PM
Hi Fergus,

I am a very very newbie!

I suggest you to exit "PROPERLY ALL APPLICATIONS"

opened ( included those you MIGTH have forgotten!!!!).

before "exiting any SESSION".

I haveencountered almost such a problem with some

older versions.

I used the "trick" completed, sometimes, with the "windows

chkdsk program" (the corresponding of"fsck program"

on the the "Fat Partition"

Good luck !