View Full Version : SMC 2532W-B wireless NIC not detected -- pcmcia config

07-08-2003, 09:56 PM
Hi all-
I have an SMC 2532W-B pcmcia wNIC that is supported by the linux-wlan-ng drivers. However, it is not recognized at boot because it is not found in the /etc/pcmcia/config-2.4 file (at least I think this is the problem). I get an 'unsupported card [57]" error on boot.

cardctl ident gives me all the correct product and manfid info on my card, but how can I edit the config file? do I have to remaster the CD or is there a way to 'fake' knoppix into using ramdisk for this file? Is there some other way to force the card to initialize since the drivers should support it?

Thanks, Matt

07-10-2003, 07:11 PM
This is the method I'm using to rty to manually install my wireless NIC. Anyone know why it doesn't work?

1: Copy /etc/pcmcia/config and config.opts to /ramdisk/home

2: use cardctl ident to get info on the card. add the following to /ramdisk/home/config:
device "prism2_cs"
class "network" module "prism2_cs"

card "SMC2532W-B WliteConnect Wireless Adapter"
version "SMC", "SMC2532W-B WliteConnect Wireless Adapter"
manfid 0xd601, 0x0005
bind "prism2_cs"

3: run modprobe prism2_cs

4: run cardmgr -c /ramdisk/home to force the new config file to be used

The error I get is:
cardmgr[1558] open_sock(socket 0) failed: Device or Resource busy.

The NIC is still not available... Anyone know what this error could be pointing to? Does this method have any possibility of even working? thanks!

09-29-2003, 08:37 PM
Anyone get this card working?

04-28-2004, 08:19 PM

I got this card to work in my toshiba laptop this past Saturday. It took me about a week to figure it out. Although I am a newbie in linux.

I am using Knoppix 3.3 installed on the hard drive.

I found out that the sample information on the SMC site uses a different manfid than what my card has. I used cardctl -ident and that gave me the correct id. Then I looked in the amtel config file in /etc/pcmcia and saw the driver they were binding to is not the standard pcmcia_cs or wavelan_cs. So I edited the conf file in /etc/pcmcia just like the sample at the SMC site suggested, but substituted the correct manfid and driver in the appropriate places.

I rebooted the machine and BAM it worked like a champ.

Up until I figured that out I downloaded drivers (found that none were needed). I recompiled the kernel 3 or 4 times (not needed).

And in the end Knoppix already has the driver, the kernel is already set correctly and all I had to do was edit the proper config files.

Hope this helped.