View Full Version : Unable to connect to the Internet ADSL-nic

07-15-2003, 11:46 AM
Hi guys,

I am really do not know what more to do. I am not able to get a working connection to the Internet from my desktop. I run knoppix r3.2, booting nodhcp and dhcp each time. I configure my network interface card with all ip and gateways itīs needed. But it doesnīt work. With a lsmod I see the kernel module I need for my nic. If I try ifconfig eth0 up a message: "SIOCSIFFLAGS: Device or resource busy" appears. A ifconfig -a shows me eth0 as non-up. I see resolv.conf and the DNSīs are there. Ok, I think, the default gateway, so I type route add default gw (ip) and next message: "SIOCADDRT: Operation not allowed". Well, what appears in /etc/gateways? nothing. And /etc/network/interfaces looks nice.

men, I need your help, Iīll loose my patient...

Thanks a lot :D

07-15-2003, 06:00 PM
Have you tried the noapic cheat code.

07-15-2003, 07:39 PM
Thanks Stephen, I tried to boot with:

knoppix noapic

but the connection to the Internet doesnīt work yet.

Any idea?

Thanks in advance ;-)