View Full Version : People who has a PCI modem and cannot get it work, READ THIS

Enoch Chan
07-16-2003, 06:56 PM
<u>This is based on my research and my own experience!</u>

PCI modems are not detected by Knoppix because most Linux/Unix only detect modems in S0 - S3 port, and PCI modems use the S4 port. Here is the bash script to make Knoppix work with the S4 port:

cd /dev
ln -s ttyS4 modem
chmod 777 modem
chmod 777 ttyS4

**Script is written by MattT**

After you enter the script in the bash shell, run pppconfig to set up a connection. Connect to your ISP using the pon <your ISP> command.
ex: pon BellSouth
Use the poff command to disconnect with your ISP.

<u>Hope this helps!!!</u> :o

07-16-2003, 11:22 PM
Actually I found this in the Hard Disk Installation Howto by David McNab. I printed it out a year ago. The version that knoppix.net links to now is different. It would be nice if this script was added to the FAQ or added to a Howto (preferably not the hard disk howto were no one will notice it :) )

07-17-2003, 12:32 AM
Only true for controller-based PCI modems. Please read :

Enoch Chan
07-17-2003, 06:32 PM
MattT, you might want to post the link to the hard-disk installation how-to (the old one) in the forum so everyone can check it out!! :o

07-18-2003, 12:20 AM
ok i dont get it im REALY getting fed up with this i did that and it says it cant find it or something of that nature and i dont know what imm doing wrong can you tell me where exactly where i put it in at what i did is went to run and typed bash and it brought up a bash shell window then i typed that in there and it dident find it or any thing man this sucks thanks

Enoch Chan
07-18-2003, 04:07 PM
Give me more details about your problem. :o

07-19-2003, 07:00 AM
well what i ment to say was that where exactly do i put the code in at the way i brought the bash promt up was i went in to the run command and i typed bash then this window poped up i suppose this is what your refuring to any ways after i got that i typed in the code then i hit enter and i dono what to do realy imm just so confused with it i dont know why iam haveing so many problems with getting online i meant i understand linux and all imm not haveing problems with that its just the whole getting connected it seem's no matter what i do i get no where with it and when i got to the ppp config i need to login as admin so i hit Ctrl+Alt+f2 and it brings it up i type login or logon dont remember but when i get there it ask's for user name and so i typed root and then i dono what to do for the pass i type root doesent reconize it then also ive typed admin for the user name and typed root as the password and i get nothing ive tried all kinds of different name's and stuf but i dont get anywhere there either and i have also went to that one site and downloaded the software thing to identify your modem and all that and i still get nowhere so i dont know what to do realy if i could get online itd be perfect that's my onley problem well i hope this is some more detail for you thanks alot for your help by the way :)

Enoch Chan
07-19-2003, 08:21 PM
If you don't enter a desktop boot script (knoppix desktop=icewm for exapmple), it will automatically log you in as root. All you have to do is press Ctrl + Alt + F2 to go into the bash shell (already as root) and set up your modem using pppconfig. This doesn't apply to HDD Install though. But you should be able to run pppconfig as root. No need for logging into the admin account and I dont' think there is even one. And the script I post above might not work because I still haven't figured out what to do if I move my modem to the second PCI slot. I will have to try that myself and tell you about it later. :D And if you want to, we can talk through IM or e-mail. :o

Enoch Chan
07-19-2003, 08:26 PM
And dude... you from Hong Kong too?