View Full Version : Knoppix doesn't work on Compaq Presario 905us

07-22-2003, 02:06 PM
hello guys!

i really want knoppix to run on my laptop. but the thing is, i cant seem to make it run... i tried ...

knoppix nousb nosound => it failed
knoppix nopci => failed
knoppix xmodule=ati nousb nosound => failed too..

i kept on getting the error..no suitable Xserver card.. my video card is ATI Mobility u1

help please!
thanks! :roll:

07-22-2003, 03:11 PM
Try 'fb1024x768 xserver=svga'. Also search the archives on Compaq or on ATI. I seem to recall there some messages about Compaqs and ATI cards.

- - Edwin

07-22-2003, 05:28 PM
Your troubles and concerns are legitimate, but the Compaq problem is really the shared and configured VRam, and Sdram on the Laptops. The way they dissimilate and do task off loading mimics lan, or or types of cards for load balancing. Depending on your operating system their are a few fixs. 1. You can of course go in and play around with your bios settings F10 on boot up, but depending on your bios which is probably Pheonix, it needs to be greater than 1.2, also I don't recomend getting in their unless your experienced. You can adjust the L2 cache to a larger value, and also your sfm to a exceptable derivative that gives more Ram caching for Knopp. 2. If your Running xp or XP Pro: start, control panel, Perf & Main, system, Advanced, Peformance settings, Advanced, Virtual Memory, Jack that way up two 2048MB both start, and end, and apply set. This will automatically put some disk space aside and the L Kernel should take care of the rest. Of course ya have to reboot after ya do this, and of course, then restart and then put the CD in. I just today ran Knopp on two lesser systems just fine. Compaq EVO n180, Compaq Persario 500e. Knopp worked like a charm on them. It ran better on them, than my cherried out workstation. 3. Another option, is if your running windows system, before you shut down, kill as many apps as possible without crashing the system. It will give more system and memory resources, then run a burn in tool for about five minutes. When that is stopped, defrag your memory, NOT HD, memory. (I'm assuming ya have the tools if your an intermediate user or above), then either use a manual crash tool, or just do a hard crash, and get that CD in their before it reboots. Knopp will run good as new, and don't worry about your client OP, as long as ya have sufficient memory, and don't have your kernel unpaged, ( unless you have 512Mb+, or 256RDRAM) Do not EVER UNPAGE THE KERNEL, Especially in windows, and even more in XP. I dont care what anyone tells you! 512MB+, or 256MBRDRAM, and large virtual memory. You Follow these steps, you will run KNOPP no problem. It is worth it. If it had English IP, or DSL, or Broadband features, I'd install it on my brand new WD Harddrive, it is already ready! The Linux Kernel crashes a bit, but still that's nothing compared to Early XP. It already blew me away. It needs better sound drivers, and better, compilers, which need to each run in seperate memory process'. Good luck. let me know. I am the Quizatsatterak.<marquee>"It is by Will alone that I set my mind in motion. It is by the Juice of Saffu that thoughts acquire speed, the Lips acquire stains, and the stains become a warning. It is by will alone that I set my mind in motion."

07-23-2003, 05:32 PM

i tried the option you told me but still the same errors.


i tried the second option you gave but still the same errors.

i kept on getting "c loop" errors plus the "No Xserver was found for your card". i also observed that when i try to boot, it takes a long time for the system to read the cd, tux on the upper left appears for about 1min then after it the text for the detection of the cd blah, blah comes but it will stop after saying "USB managed by hotplug." from there the error messages comes out.

my knoppix is 3.2 beta
and the drive m using is a dvd drive

btw, thanks for the replies. still need more of your suggestions.

07-23-2003, 06:39 PM
Hey Ronin! Sorry those solutions didn't work. If ya feel brave, go ahead and try the other solutions I suggested. If you indeed have a DVD on that thing then the spin rate would not be a problem, the error that you get is common for M version ATI cards on Laptops. Another option may be to go to ATI.com and update, the CONTROL PANEL TO THE LATEST VERSION. ATI WONT HAVE AN UPDATE DRIVER FOR THAT CARD ON THE LAPTOP, BUT AS LONG AS THE M5 OR M6 ARE 32MB YOUR O.K. I AM WORKING RIGHT NOW 1:34pm EST. SO I NEED TO RUN, BUT I WILL PUT MY THINKING CAP ON, AND GET BACK TO YA. Regarding the slow boot time, well is it really that bad? I mean common :lol: It is worth the wait. KNOPP alone is really superior as a rescue disk, amazing. I noticed Lindows.com is offering a similar situation with their working OP. I enjoy Lindows but KNOPP is really a superior environment for many other things. The confusion lies in the multiple command console options and boxes. I got so excited I started launching Linux, Python, and a whole string of others at once. Pretty funny behavior, but once I settled down so did my spinning Rom Drive. Later Quiz

07-24-2003, 04:12 PM
thanks for your help quiz...

i already update my video drivers... my video driver is ATI mobility u1,
but now it is RADEON IGP 320M, its has a memory of 16Mb.

thanks again for the help!

07-27-2003, 04:20 AM
I was able to get the latest version of Knoppix (v 3.2 2003-07-26) running on my Compaq 920CA using the following:
knoppix fb800x600 nousb noagp

I am betting I don't need the noagp, but I haven't tried it yet.

I also know that the following works as well:
knoppix fb1024x768 nobus noagp

07-27-2003, 05:22 PM

i tried to use the options you ask me (knoppix fb800x600 nousb noagp) but i still got the same errors... no Xserver was found suitable for your card.

was that nousb or nobus?

thanks for the replies.

07-27-2003, 06:50 PM

07-27-2003, 06:58 PM
Make sure you are using the same version as I was. I had not tried the July 24th release, but I do know that the June 6 release did not work for me (and neither did any of the previous).

07-28-2003, 07:54 AM
ah ok...

i have yet to try the version you said.

il update you as soon as i get a copy of that version of knoppix.


08-01-2003, 09:40 PM
Wait a minute. I was rereading this thread and spotted:

i kept on getting "c loop" errors plus the "No Xserver was found for your card".

cloop errors can indicate a bad image on the CD. Did you download and burn yourself? Did you do a md5 checksum? Try booting with the 'checkcd' cheatcode.

- - Edwin