View Full Version : nvidia GeforceFX 5600 not working (Help !!!)

07-25-2003, 11:12 PM
Hi all,

I recently downloaded Knoppix and it rules man, it boots up and is ready real quick and is as easy to use, "if not better", than Mandrake :lol:

I bought a MSI GeforceFX 5600 128MB DDR with VIVO and DVI at a PC show recently to replace my Geforce4MX, and the card is great on windows, however Knoppix does not recognize the card.

I have tried a few command line switches that are listed after pressing "F2" at boot, but the monitor goes blank on the Analogue VGA outlet.

Does anyone know if this version of Knoppix supports the card and if not any way I can get it to display properly until Knoppix supports this card in a newer version.

JamesX............ :wink:

P.S. Sorry for mentioning the "W" word on a Linux website :lol: I am weening myself onto Linux and will soon never have to mention the "W" word again 8)

07-26-2003, 01:37 AM
Did you boot with xmodule=nv?

07-26-2003, 01:11 PM

No I didn't try that, but as Knoppix previously picked up my Geforce4MX it must have used that module before, and I assumed it would try a nearest match module for the new card if it didn't have an exact match.

OK I pressed "F2" at the boot screen and then typed "knoppix lang=us xmodule=nv" and it worked straight away no problems. 8)

Woo-hoo :lol: I got me Linux back, every day I use Linux is one more day closer to weening myself off of Micro$haft. :lol:

I suppose this should work with any nvidia GeforceFX 5200, 5600, 5800, and 5900 chipset based Graphics card Ultra version or Normal

Nice one Rickenbacherus you just solved a lot of peoples worries in one quick post. 8) , damn the Linux community rules :D


08-05-2003, 05:54 AM
james what exactly was wrong with yours?
i have geforcefx 5600 and i cant get knoppix to work, maybe we have same problem?

i am going to try what u did and see if it works.

08-05-2003, 08:07 AM
thanks works like a charm now

09-09-2003, 09:12 PM
I had the same problem to. But i discovered already