View Full Version : Cups doesn't work after hdinstall

01-15-2003, 01:24 PM
I get a message after the hdinstall when I try to use my cups printer that the cups server is not running.

What should I do?

01-15-2003, 04:31 PM
Hey, I am a little newbie-ish...but:

1. On install, did you tell Knoppix to start cups on boot?

2. Have you tried typing "http://localhost:631" in your browser(mozilla or konqueror)? That should let you configure cups.

Either way, good luck!

xeta prime

01-18-2003, 03:41 PM
If you want to start the Cups-server automaticly you must do (as root):

cd /etc/rc5.d
ln -s ../init.d/cupsys S80cupsys


02-20-2003, 08:27 PM
I reinstalled with the most up to date iso and cups works no problem now. Still have the mii-tool problem though!

10-04-2003, 08:48 PM
If you want to start the Cups-server automaticly you must do (as root):

cd /etc/rc5.d
ln -s ../init.d/cupsys S80cupsys


I had this same problem and tried this, but it did not work. I still get the error message:

Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: connection refused.

Any other ideas?

A. Jorge Garcia
11-08-2003, 04:20 PM
OK, I tried http://localhost:631 after a knoppix-installer and can't get it to work right on local printers and not at all on remote printers over a LAN.

First, I created a local printer as root and it only works for root. I thought that it could work for any user logged on that PC?? Also, I created a local printer for users added to this server (adduser, /home dirs, etc). The only user that this worked for was for the user defined during the installation process. This user could print locally and root could use this printer definition too. However, if I do this with other users I add, they can't print, but root can use their printers to print. This is weird, right? What's wrong with this?

Secondly, how do you define a remote printer over a LAN using http://localhost:631 - what is ipp, etc?