View Full Version : Help. Modem dials, connects to ISP. Network inaccessable.

08-06-2003, 10:53 PM
I just received a copy of Knoppix 3.2 in the mail.
Set it up, got it running. Set up my modem, it dialed in. It connects, shows details, and minimizes itself.
But I cannot ping any address, I can not load any address.

Version I am trying to use lists itself as 7-25-2003 beta.

I took out an old version I had, Version 3.1 dated 9-22-2002 and tried logging in.
Modem dials, connects, and works flawlessly.
Which leads me to believe its something new in this version.

Computer is a P4, 512 MB ram, modem is an external US Robotics model 5686D

I tried connecting with kppp. I tried PAP/CHAP, PAP, terminal.
Tried going in through konsole and using pppconfig. But I was unable to get that to work.
I tried inputing the DNS numbers into the dialup dialog, and then I told it to determine it manually. Neither makes any difference. (And my version 3.1, I left everything default, changed nothing except uername/pass and isp #, and it worked OOTB).

Suggestions? :(

And something without having to redownload a 700 MB file.
I want DSL. :\

BTW, MD5 sums check out, CD isn't corrupt or bad.

Anyway to remaster with an older/newer something or other (pppconfig? kppp? whateveR) to get it working?
I may be a linux n00b, but I'm an expert googler, so a little suggestion can go a long way. :erm: Or something. :D

08-07-2003, 07:55 PM
I'm having nearly the same problem: Hard drive installation of Knoppix 3.2 with an ISP ("FreeISP") that connects via KPPP and allows me to ping the host, but which the browsers can't use (trying any Internet link instantly returns "Could not find www.xyz .com."). This is the case whether I'm root or user, which suggests that this isn't a permissions or group membership problem for resolv.conf or another important file somewhere. FreeISP works fine with the same KPPP settings in Mandrake 9.0 on the same computer, so it doesn't seem like a hardware problem.

Here's a twist, though -- I have another ISP ("SchoolISP") that does yield a successful connection! I'm hoping that the difference between the two ISP accounts provides some clues. FreeISP works in Mandrake with KPPP account defaults -- all I need to do is provide username, password, and a couple of DNS IP addresses provided by FreeISP. SchoolISP also works, in Mandrake and Knoppix, with KPPP defaults, with me providing only username, password, and a login script.

I've found several forum threads on the "connect, ping, but not browse" problem, and maybe they'll help Zzymdaexi:

"Modem Connects but No Internet" (http://www.knoppix.net/forum/viewtopic.php?t=2558)

"No Internet after HD Installation Problem" (http://www.knoppix.net/forum/viewtopic.php?t=2711)

"Suddenly Can't Connect" (http://www.knoppix.net/forum/viewtopic.php?t=2703)

"Can Ping Router but No Internet" (http://www.knoppix.net/forum/viewtopic.php?t=3359)

Unfortunately, none of them seems to have really nailed down what's going on. I seem to be the only one who's experiencing the problem for one ISP but not with another. Does anyone smarter about ppp (or who simply solved this problem with good old dumb luck) have any suggestions? Thanks!


08-09-2003, 06:51 PM
just a 'same here', I'm afraid. I have gone through exactly the same processes as you, with the same - i.e. NO - results. I'm sending this on my other box set up with 3.1. Previously, it's worked perfectly for dialup. On the same pppconfig. I have copied the pppconfig settings across. The only difference I can see is that the one that works is 3.1 and the one that doesn't work is 3.2.

still thinking about it... but I'm an elderly newb


08-11-2003, 06:29 AM
And six others with the same problem in the four threads I linked to above. Some found answers, but I've looked at those threads carefully and it seems they had issues prior to the one we're identifying here.

This seems to be a Real Problem. Do any of the "Power Knoppix" people on this forum have any clues for us? I'm eager to test farfetched theories, don't need a definitive answer (though if you have one, don't hesitate!). Thanks for anyone's input.


08-12-2003, 03:23 AM
Well, I fixed it!
Thanks to another thread.

Apparently the version of knoppix I have has problems with DNS.
I think thats why the next release had a patch, and the day after pppconfig or something was downgraded. Probably just has problems.

My copy is dated, er, like 7-25. There was an update the 26th, patching dns or something. Then an update the 27th downgrading pppconfig or what have you.
Maybe new updates'll help someone else.

Or atleast knowing which packages or files to fix and later to get stuff up and running. :D

Would like to know how to patch knoppix so that it works off the CD without having to do the workaround I used. But, hey, whatever.

Oh, what I did:

In kppp I set it up to manually use DNS. Since it didn't work automatically.
Still didn't work.
So, checked another thread. It said to go to /etc/ and edit resolv.conf
Did that, added in the DNS nameservers, and everything loads up fine.

Because I could ping IP addresses fine, and load pages where I had the IP address. Just no pages.
But its all working now. :)

Hope you find help for your problem, unamiccia

08-13-2003, 03:26 AM
Congratulations! My HD install is from a May 2003 build, so I suppose I should try the latest version, too. That won't happen tomorrow, though (modem at home, little opportunity to burn CDs on the networks where I have access), so I still welcome any advice that comes to this thread.

Everything else runs wonderfully.

Yay, Knoppix!


09-10-2003, 03:46 PM
Yeah, to check if it's the resolv.conf problem, ping an IP address, i.e.:

Or in the browser put the IP address instead of the domain name.

10-07-2003, 02:09 AM
in my case i had a conflict between ppp0 and eth0(which knoppix had setup as the default to the interet)

as root do

ifconfig eth0 down

then try kppp again