View Full Version : wireless Ad-hoc, 2 IBM Thinkpads, Orinoco Gold

08-25-2003, 08:37 PM
I am desperate. :( I tried to get a wireless Ad-Hoc connection with WinXP sp1 and my two laptops for 2 days now. It did not work. So I switchet to knoppix. Any better here either. I searched for all the information I could find on the Internet and this board. I configured my Orinoco Gold cards with wlcarconfig, asigned static ips, checked the signals with wavemon. The cards keep sending signals (tx in wavemon) but there is no rx. They keep blinking, it makes me real nervous.

So I think the cards seem to work correctly, but they do not connect. What in hell am I doing wrong? Does anybody have a solution for my problem? :?:I really need this wireless connection.

Thanks for every response, fluppel

04-12-2004, 03:51 AM
Can you give the results of running the following commands:

ifconfig -a

05-05-2004, 06:32 AM
I am running a Thinkpad 380XD with a Dell Truemobile 1150 wlan card (its a rebadged Orinoco Gold).

All I can get it to do is flash its lights. the Knoppix (and Kanotix too) wlancard config utils says "No Card Detected", usually (I was able to get it to go through after running wlan-ng from /etc/pcmcia/). On boot it modprobes orinoco, orinoco_cs and hermes. lsmod shows those as being in. Ifconfig -a shows eth0 as being there with no IP, no packets sent or recieved (or even dropped) but a slew of errors under tx. iwconfig shows it as being there, seemingly ok except the access point being 44:44:44:44:44:44 (which seems odd to me). I'd copy and paste it, but I'm not on that machine now (since that one doesnt have net or lan access currently.

05-06-2004, 12:31 AM
Check lsmod again and see if there is a 1 next to orinoco_cs. Also, what are the errors under tx. And, under iwconfig does it show your card in managed mode?

05-06-2004, 02:15 AM
Its in managed mode, and orinoco_cs has a 1. As far as the errors, I have no clue. Relative Linux newbie with zero wlan experience. when I get home and I plug into my home network, I'll post the logs I have of iwconfig, ifconfig, lsmod, and lspci (borrowing a computer at the moment since I am not near where I live, was out of town for a court hearing).

05-06-2004, 08:01 PM
These I got from running off cd, cause the version of Knoppix I have puked some error about the drivers being compiled with version 15 while the utility was compiled with version 16.

root@ttyp0[pcmcia]# lsmod
Module Size Used by Not tainted
autofs4 9204 1 (autoclean)
serial 47044 0 (autoclean)
usb-uhci 22672 0 (unused)
usbcore 59788 1 [usb-uhci]
af_packet 14184 2 (autoclean)
orinoco_cs 4756 1
orinoco 39612 0 [orinoco_cs]
hermes 6000 0 [orinoco_cs orinoco]
ds 6452 2 [orinoco_cs]
yenta_socket 10080 2
pcmcia_core 42048 0 [orinoco_cs ds yenta_socket]
apm 10220 2
rtc 7272 0 (autoclean)
cloop 9348 2

root@ttyp0[pcmcia]# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:02:2D:A9:B7:A6
RX packets:18 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:1101 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2330 (2.2 KiB) TX bytes:0 (0.0 b)
Interrupt:3 Base address:0x100

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:76 errors:0 dropped:0 overruns:0 frame:0
TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4824 (4.7 KiB) TX bytes:4824 (4.7 KiB)

root@ttyp0[pcmcia]# iwconfig
lo no wireless extensions.

eth0 IEEE 802.11-DS ESSID:"NETGEAR" Nickname:"HERMES I"
Mode:Managed Frequency:2.462GHz Access Point: 44:44:44:44:44:44
Bit Rate:2Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry limit:4 RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0/92 Signal level:134/153 Noise level:134/153
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

05-06-2004, 09:09 PM
It looks like you have your card properly configured but it's not seeing your AP, and your laptop is not getting a dhcp assigned IP address.

Do you have a router/AP and is it configured for dhcp? If not, what kind of setup do you have.

05-06-2004, 09:16 PM
One more thing, it looks like you are using channel 12. Did you buy this card outside the US? You may have to change that if it's not compatible with your AP.

05-06-2004, 09:20 PM
Forget that last post. I'm looking at the wrong table.


05-08-2004, 05:22 AM
Its a router/AP, and as far as dhcp config, I am not sure. Its not my AP.

As far as specs, its a Netgear MR814 v2 router.

05-08-2004, 02:15 PM
I've got the same card as you do and have used it in several different versions of Knoppix without any problems.

I would check to make sure you're on the right channel, have the correct SSID, using a valid WEP key and if the AP is using MAC filtering, your MAC is on the list.

05-08-2004, 05:28 PM
I'm using the same channel (verified that several times), the ESSID I've checked several times and also tried having it set to use any, my MAC is already on the list (had to manually do it since the router didnt detect my card) and I copied the WEP key down letter for letter and doubled checked that too.

I did some looking last night on the web and found a couple reports of some people with the same issue, this model router not seeing some cards and therefore DHCP not working.

How would I switch between 64 bit and 128bit encryption, or is that done automatically depending on what key I give it.

05-08-2004, 06:43 PM
Ok, I disabled the encryption on a whim (tried it cause the one page I read where the guy had the same problem where he couldnt get a DHCP connection with the same model router I'm using said that it was the encryption that was knocking him out), and I was able to connect with the laptop and card without any problems (as a matter of fact, I'm using it as we speak). Now, find out how to have the encryption AND be able to connect...

Don't know if its a router issue, or if the card is trying to use 64 bit encryption (the Gold is supposed to be switchable, but dunno if thats automatic or manual)