View Full Version : Howto update to kernel 2.6.0-test4

Henk Poley
09-04-2003, 04:29 PM
The debian kernel-image-2.6.0-test2 didn't even boot on my machine. I have compile kernels before, with now and then a succes story. I encountered the following problems with 'deploying' kernel 2.6.0-test4:
- blank console (solved)
- aRtsd (KDE soundserver) will only use OSS-emulation API of ALSA (solved)
- network card won't work (solved)
- mousewheel (Logitech mouse) won't work in X (solved)

I downloaded the Linus-kernel, applied no patches. Used "make menuconfig" to configure the kernel. At first I was a bit overwhelmed by all the (already expanded) options. I did a "make defconfig" to get a quite minimal configuration to start editing on.

Some tips:
- use make defconfig to get an tiny default configuration without all/most options expanded.
- compile all framebuffer support (for graphics on consoles) you need into the kernel else you might end up with a blank screen like I did.
- apt-get install module-init-tools, to get a 2.4/2.5/2.6 compatible init. Testing and unstable have a newer version.
- compile ALSA as module, this might improve compatibility with older apps.
- apt-get remove knx-alsa ; apt-get install alsa-utils/testing alsa-base/testing alsaconf/testing, to get a 2.6 compatible ALSA-lib/utils.

Usefull docs:
"The post halloween doc" (ftp://ftp.kernel.org/pub/linux/kernel/people/davej/misc/post-halloween-2.5.txt) (list of known problems+solutions with late 2.5 kernels)
HowTo Upgrade To The 2.6 Kernel (http://kerneltrap.org/node/view/799) (decolapsing all comments can be helpfull)


make mrproper
make menuconfig or make xconfig
make modules_install
make install

Modify your lilo.conf

How I fixed the problems I encountered:

- Though I did compile the framebuffer as module, it didn't solve the blank console by compiling it into the kernel. Also enableing the nVidia Riva/GeForce support didn't help me either (i have a Geforce4 MX440). So after some fiddeling I disabled "VGA 16-color graphics support" and enabled "VESA VGA graphics support" in the "Graphics support" menu. If I enable 16-color VGA my console remains blank.

- Upgrade ALSA to fix the wierdness with aRtsd
I first tried to solve it by compiling ALSA als module, I read somewhere that ALSA is new in the kernel and that some apps still require ALSA modules like in the ol' 2.4.x days.

apt-get remove knx-alsa
apt-get install alsa-utils/testing alsa-base/testing alsaconf/testing
alsa-utils from unstable requires a new libc6 (>= 2.3.2-1), didn't want to upgrade...

One of the ALSa packages will ask what drivers to load, select the card(s) you have configured for your kernel.

- boot with "acpi=off" to get my sis900 networkcard working, or compile the kernel without any powermanagement. This seems like a gross bug to me.

- Apparently the autodetect of the "mouse-protocol" in X is broken for kernel 2.6, set the used mouse protocol from "PS/2" to "IMPS/2". Snippet:

Section "ServerLayout"
InputDevice "PS/2 Mouse" "CorePointer"
Section "InputDevice"
Identifier "PS/2 Mouse" # Match this with InputDevice above
Driver "mouse"
Option "Protocol" "IMPS/2" # Change this
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"

09-04-2003, 05:44 PM
make bzImage && make modules && make modules_install
mv arch/i386/boot/bzImage /boot/bzImage-2.6.0-test4
mv System.map /boot/System.map-2.6.0-test4
cd /boot
ls -al System.map
rm System.map
ln -s System.map-2.6.0-test4 System.map

The above is the old way of making 2.4 the new way is to do the following:

make mrproper
make menuconfig or make xconfig
make modules_install
make install <------ this installs you kernel into /boot

Modify you lilo.conf

Go to http://www.minion.de/nvidia.html to get the patch for the nvidia driver from nvidia.
Follow the direction and you are off and running.

Henk Poley
09-04-2003, 05:52 PM
I'll update my post, thank you. People on kerneltrap.org already pointed out that this is the old way, but they weren't specific on what the new 'way' was.

The old one still works anyways :-)

btw, can you be more specific on the lilo.conf? Do you know what is the diff between the different initrds?

And I might give nVidia a try again, last time I installed Knoppix the description from the forum didn't work (probably some change in the automated installer).
nVidia driver works :-) now to get Tuxracer to play nice with aRtsd
Quick googling revealed the command "artsdsp tuxracer"

09-04-2003, 09:24 PM
Because the symbolic link are already created for the copied vmlinuz files you only have to add or change following in your lilo.conf

# for your old image mlinuz-2.4.21-xfs

#new 2.6 kernel

I don't use initrd in my 2.6 kernel.

09-05-2003, 12:47 AM
Just do it the debian way :

tar xvfj kernel-source*.tar.bz2
ln -fs kernel-source* linux
cd /usr/src/linux || exit
make menuconfig
REV=${HOSTNAME}.$(date +%Y%m%d%H%M)
make-kpkg kernel_image --revision=${REV}
dkpg -i ../*.deb

2.6.0-test4 worked for me on amilo laptop @ http://rzr.online.fr/linux

then how to select modules , to be loaded on next reboot ?

10-31-2003, 01:57 PM
Also the debian way (CHANGED)

I am just installing the kernel-source-2.6.0-test9 on a Knoppix 3.3 HD-Install on ThinkPad R31 2656-G :)

First got the kernel-sources and thinkpad-sources:

apt-get install kernel-source-2.6.0-test9
apt-get install thinkpad-source
cd /usr/src
tar xzvf thinkpad.tar.gz

Now i am doing xconfig:

cd /usr/src/kernel-source-2.6.0
make xconfig

Now i am ready, to compile the kernel:

cd /usr/src

# Important for make-kpkg:
rm -rf linux
ln -s kernel-source-2.6.0 linux

# Remove the debs
rm -rf *.deb

# Build the kernel
cd linux
make-kpkg kernel-image

# Build the modules
make-kpkg modules-image
cd ..

# Install new kernel and modules
# Removes any files!!!
rm -rf /lib/modules/$KERNEL*
dpkg -i kernel-image-$KERNEL*.deb
dpkg -i thinkpad-modules-$KERNEL*.deb

# Absolute necessary!

The script finds its way and creates the appropriate debs (kernel***Custom.all.deb) in the directory /usr/src/. for install (-> dpkg -i kernel*Custom.all.deb), installs the kernel and modules and reboots the machine - works perfectly.

Nevertheless you an use the old way and This script works for me right now:

cd /usr/src
rm -rf linux
ln -s kernel-source-2.6.0-your-version linux
cd kernel-source-2.6.0-yourversion
make xconfig
#load your saved ".config" and change it
make modules
make modules_install
make install

Bye Axel

10-31-2003, 02:09 PM
Dear apos,

please keep me informed about the installation and your impression of the 2.6 kernel....

Best Regards
Mike Kranidis

10-31-2003, 02:55 PM
Hello again,

so with the above (changed!!) method I gained success and everything went o.k. Be sure not to compile fb-vga16 into the kernel, if you like to boot with vga=971.

Have fun.

11-23-2003, 02:37 AM
I would suggest to those users of Knoppix out there,

NOT to install the 2.6.0 kernel just yet.

the kernel as it stands now, is VERY buggy, and even when its released rumor has it it will still be unstable for awhile.

so I would suggest to everyone out there, NOT To install the 2.6
kernel yet, unless you absolutely need it.


11-23-2003, 04:51 AM

I would agree except for people that are interested in activly interestred in reporting bugs. I know there is a fair amount of interest in getting some of the kernel bugs reported, but I have heard untill recenlty not enough people were putting it through its paces.

If you are willing to test and report bugs to the right people (NOT HERE) then please do get the 2.6 kernel.

01-29-2004, 08:04 AM
I am having problems running a boot net setup of ltsp using clusterknoppix I have just cluster knoppix installed but am having trouble getting my pentium 166 to load it detects the server and show splash creens then it halts with a Kernel error NULL ??? with violation and the hangs

Should I build a new kernel to allow this older machine to run if I do will that mean having to make it recognize both machines within one kernel

I am not familiar with any of this kernel building and not sure how to proceed to get this older machine to be useful once again other than an anchor for my noat

Any assistance would be greatful thanks