View Full Version : Good install, no network

01-21-2003, 08:28 PM
The install went well and when I said yes to DHCP the install said OK. However, after restarting I don't have any network access.

I didn't find any error messages inthe log files, ifup doesn't help, mii-tool doesn't do anything.

I even backed off to a 3C950 network card. Still no network.

Any ideas? :?

01-22-2003, 04:02 AM
What does dmesg report? I don't know dmesg that well but I'm sure it reports NIC status. See what is reported for eth0. What does ifconfig return?


01-22-2003, 08:14 AM
I had the same problem, which I fixed. I already have a linux router listening for DHCP requests. I saw that DHCP failed during boot on my Debian/KNOPPIX install. I beleave its because it is trying to do the same thing as my router. I ran ifconfig -a to get a list of all the adapters, and it did see eth0 as my ethernet card. I then ran pump and it configured my adapter and set up routing. What pump does is send a DHCP request, which is what my router is listening for. When you run pump, you have to specify the interface that you are using. I have not added this to my startup yet as I am limited in my time. When I do I will add to the post.

01-30-2003, 07:45 PM
Edit /etc/network/interfaces and make sure the following two lines are in it:

auto eth0
iface eth0 inet dhcp

If you don't use dhcp, enter the ip address and other relevant data according to the manpage for "interfaces" (man interfaces).

Worked for me, YMMV.