View Full Version : Newbie cant Use PCMCIA (LAN) on Toshiba Satelite

09-07-2003, 05:37 PM
Hello. I am a newbie. I installed Knoppix 3.2 (v.07.25-de) on my Notebook Toshiba Satelite 4100XCDT on HD. I enjoy it verry much. By and large all works fine. But there is one important Question/Problem:

How can I use (install) my PCMCIA (LAN)?
It is a CNet, Single Point 16 bit. The Notebook gots a simple i82365 PCMCIA Controller. In Bios I suppose the option "PCIC Compatible" is the right on.

I can`t find a special Driver from CNet.

Did I have to compile the Core?
On other Notebooks like myne It works with SUSE:

In my german Book of "Debian Linux Guide" it is written to use "dbootstrap" while installing (?).
Question: Can I use ist also after Installing on HD? Where is dbootstrap and how can I start it?
Moreover there is something described with:
"... or use manually insmod and rmmod...." WHATs THAT?

My aim for the short next time beeing in Internet without MS. I have to go out over my Router (DHCP).

Wat should I do? Compile or use a tool? (Or something else?)

THX for help. -Greets, mike

09-24-2003, 09:22 AM
The pcmcia controller is ok, I never experienced problems in linux with the i82365 PCMCIA Controller.

Is your card found?
run ifconfig as root if in the output there is no eth0, your card has probably not been configured. (and when you boot with the card in a slot, you probably heard two low toned beeps when pcmcia started)
Probably this only means you have to enter its description in the correct configuration file.

First find out what driver you lan card is supposed to have:
Search on the net for people using your type of card and linux.

As root run
cardctl ident 0 (first slot, or 1 second slot)
The output is like
product info: "Cnet", ".....", "...."
manfid : XXXXX, YYYYY
function: 6 (network)

Don't be surprised when something like
card "Bromax" or whatever turns up on your screen, the outside and inside of pcmcia cards are often different.

Use the output to create an appropriate entry in /etc/pcmcia/config

card "Cnet"
bind "yourdrivername"

either restart pcmcia or the easy way is a reboot
When pcmcia is started you should hear two high pitched beeps if everything is ok and you card has been recognised.

ifconfig should now output info about the network card

if needed (you hear two high pitched beeps but no eth0 shows up after ifconfig)
You can change your networking parameters in /etc/networking/interfaces
(man interfaces for the format)
Next run as root /etc/init.d/networking restart

10-07-2003, 09:49 AM
I have a similar problem with my laptop. I have Xircom PCMCIA network/Modem card. It worked fine with debian. The cardmanager recognises the card. But no network connection.

I modified my /etc/network/interfaces file as described.

e.g. auto eth0 etc.

When I type /etc/init.d/networking stop

it reports an error message with bootpc. I see that other people are having lots of problem with networking. When I was installing Knoppix to HD it reported an error with DHCP. It just could not find the PCMCIA network card.

BTW the networking did not work when I booted KNOPPIX from CD.
The same problem exists with HD install.

12-02-2003, 05:24 AM
I have a similar problem. (PCMCIA/NIC)

I can load Debian Woody without a problem. Pcmcia is recognised as needing pcmcia_core, pcnet_cs, 8390 - wd80*3, i82365 and ds, however when loading Knoppix it insists on installing the yenta_socket module and drops the i82365. Removing the incorrect ones (rmmod) is fine. Try as I might I cannot install (insmod, modprobe) the correct modules.

All I want to achieve is as great a system on my laptop as I have on my desktop. Any help or hints to resolve this impasse would be highly appreciated.


12-12-2003, 04:56 AM
Have you tried the other PCMCIA controller options in the BIOS? Try setting it on "auto-selected".

12-12-2003, 12:34 PM
Thanks for the thought but I don't think this is the solution. The reason I say this is because the laptop's bios went out the window years ago and the normal Debian/Woody install on kernel 2.4.18-bf sets it up in auto mode quite well.

I've continued to 'google' since posting the request for help. It would appear that there's a ? on the inclusion (or otherwise) of i82365 in the 2.4.22-xfs kernel. Whether this is correct or not I'm not experienced enough to say.

Any further ideas are always welcome.


01-22-2004, 01:33 AM
I managed to get some kind of PCMCIA services working on a Toshiba TE2000, here's what I had to do.

Boot with nopcmcia (otherwise it would hang) and noddc (to get a full 1024x768 XWindows), then I could experiment with PCMCIA at a useful prompt.

As root, doing "insmod pcmcia_core" worked, but following with "insmod i82365" would cause a hang. However, doing "insmod i82365 do_scan=0" would work. Follow that with "insmod ds" and "cardmgr" to get a pcmcia presence in "cat /proc/devices".

I put in a Cisco Aironet 350 card, and it detected it correctly, but I had further problems that I assume were un-related to the PCMCIA setup.

I've got my Knoppix install running from the hard-disk, so I edited the /etc/init.d/knoppix-autoconfig script to add the "do_scan=0" bit in the right place, then took out the nopcmcia from my lilo.conf, redid lilo, and it boots fine. Still have "noddc" though. :)

This was easier tweaking than my previous attempts at a Linux install, so Knoppix does make like slightly easier!

Andrew Scott

01-22-2004, 03:27 AM

Thanks for the post. I'd forgotten I'd left the ? hanging.

I've not been idle in the mean time so I thought it only fair to bring this post up to date with my learning experience.

It seems that Knoppix hides the PCMCIA setup under the power supply icon on the bar. If you right click on it, it'll give you the option of starting the PCMCIA function. Once this is done all you need to do is click on the Knoppix icon on the same bar and choose the network option which then allows manual setup of ip, gateway, dhcp, dns etc.

This seems entirely reasonable for a laptop which may fluctuate between different networks but I must say I'm interested to know how this can be achieved automatically on start - my current research project.