PDA

View Full Version : hdinstalled booting off floppy



hickorynut
01-23-2003, 05:49 PM
I installed knoppix on a hd partition, keeping winme on another partition.
I use a boot floppy to load knoppix. When booting I get "boot" then
I have to hit the enter key or wait several seconds. Then it loads
vmlinuz. Then it says I have passed an undefined node number and
to press return to see video nodes available. I do that, choose "0"
and it continues to load. How can I define a node so I won't keep
getting this error? My version is 01-01-03 disk, I am using it on one
stand alone desktop computer, not a system. I have read so much
that I've gotten myself confused. thanks.

Dave_Bechtel
01-23-2003, 06:40 PM
--The kernel is having trouble with the video MODE.

A couple of things to try:
' knoppix vga=normal '
' knoppix vga=ext '

' fb1024x768 '

(Hit F2 at the boot prompt for more codes.)


I installed knoppix on a hd partition, keeping winme on another partition.
I use a boot floppy to load knoppix. When booting I get "boot" then
I have to hit the enter key or wait several seconds. Then it loads
vmlinuz. Then it says I have passed an undefined node number and
to press return to see video nodes available. I do that, choose "0"
and it continues to load. How can I define a node so I won't keep
getting this error? My version is 01-01-03 disk, I am using it on one
stand alone desktop computer, not a system. I have read so much
that I've gotten myself confused. thanks.

RockMumbles
01-23-2003, 11:44 PM
Your video card won't support the knoppix default video mode, so starting with knoppix vga=normal should work OK.

(WARNING: I don't know exactly how knoppix boots from floppy, if it's a lilo floppy or ???)
If it uses lilo and you want a permanent fix so you will boot automatically in the correct video mode you will have to edit your lilo.conf file (as root) and change the video mode in there. FIRST make a backup of your existing lilo.conf file just in case!
( cp /etc/lilo.conf /etc/lilo.conf.bak )

Your /etc/lilo.conf file should have a section near the top like this:
<snip>
#
lba32
#
vga=791
#
</snip>

put a hash ( # ) in front of the vga=791 so it looks like this:

#
#vga=791
#

save the file, and then make sure to rerun lilo, with the command:

/sbin/lilo -v

(if you don't rerun lilo the changes won't take)

I can't guarantee this will work with a boot floppy.

HTH

rock

Rixel
01-24-2003, 09:06 AM
When booting from floppy, you can modify the syslinux.cfg file to reflect the boot options that are required. First, figure out what boot args need to be done, then add them to the append statement after the default setting in the file. This works for me just fine. You can even add floppyconfig to have the system look back to the floppy for the configs.

hickorynut
01-27-2003, 04:37 AM
The vga=normal did the trick. Many thanks to the responders.