View Full Version : Can't set hostname.

09-23-2003, 10:35 AM
Hello, I tried knoppix 3.3 and still I can't get my cable connected to the internet, I guess
because my provider needs my hostname (computernaam). It simple refuses connection without that, has anyone a idea how I can set that before I try things like
netcardconf etc.

09-24-2003, 03:57 AM
Edit the file /etc/hostname as root and put the name in there then run netcardconfig. The command would be sudo gvim /etc/hostname if you are running from the CD.

09-24-2003, 10:58 PM
Thanks Stephen, I could set my hostname, further I seem to have another problem,
because after that, netcardconfig says:

sending DHCP broadcast from device eth0Operation failed

Whatever I found on another forum a suggest to type in a shell:

pump -h `computername` -i eth0 ( as root on hd install)


sudo -u root pump -h `computername` -i eth0 (from running cd)

After that I was finally online, thanks for answering, still I am wondering why
I can't configure netcard (realtek) and modem (motorola) in normal way.

09-24-2003, 11:15 PM
still I am wondering why
I can't configure netcard (realtek) and modem (motorola) in normal way.

Good question that I don't really have a good answer for other than sometimes with hardware it's a toss up whether it will work in various combinations, good to hear you got it going though.

09-26-2003, 11:45 PM
i have the same issue as Wim...
using Knoppix v3.3 on CD

i did the "sudo gvim /etc/hostname" thing and changed the line in that file to my hostname; CP121041-A
that went fine, even went back to check if my changes got saved, and it did.

but when i ran this thing here:
sudo -u root pump -h 'CP121041-A' -i eth0

it waits some seconds and then it says:
Operation Failed

i ran netcardconfig but... no luck :(
got the same error as Wim :(

does anyone has any ideas?
keep in mind, i'm a complete n00b

09-27-2003, 04:16 PM
Hello FunForum,

Probably you used the ' ' signes, try without, so:

sudo -u root pump -h computername -i eth0

maybe eth0 can be eth1 depends on your ethercard.